This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 180342 - sudo prompts for passwd when NOPASSWD is used in conjunction with Host_Alias
sudo prompts for passwd when NOPASSWD is used in conjunction with Host_Alias
Status: CLOSED DUPLICATE of bug 170023
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sudo (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 09:09 EST by Harri Sylvander
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 10:30:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harri Sylvander 2006-02-07 09:09:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060130 Red Hat/1.0.7-1.4.3 Firefox/1.0.7

Description of problem:
NOPASSWD does not work when used in combination with Host_Aliases. Defining a Host_Alias for multiple networks breaks functionality:

/etc/sudoers 
---snip---
Host_Alias TEST_NETS = \
                       192.168.1.0, \
                       192.168.2.0, \
                       192.168.3.0

Cmnd_Alias TEST_CMDS = /bin/touch /tmp/test
Defaults        timestamp_timeout=0, !lecture
nobody TEST_NETS = NOPASSWD: TEST_CMDS
---snip---

Running sudo will prompt for password.


Version-Release number of selected component (if applicable):
sudo-1.6.7p5-30.1.1

How reproducible:
Always

Steps to Reproduce:
1. Add multiple networks in a Host_Alias and use NOPASSWD(see sudoers example in description)
2. Run

     $ sudo /bin/touch /tmp/test 


Actual Results:  User will be prompted for password.

Expected Results:  A file /tmp/test should've been created with root:root owner w/o password prompt

Additional info:

Tried grabbing sudo source from http://www.courtesan.com/sudo/ and compiling without any extram params(./configure; make; make install). Using same /etc/sudoers produced expected result.
Comment 1 Karel Zak 2006-02-07 10:30:47 EST

*** This bug has been marked as a duplicate of 170023 ***

Note You need to log in before you can comment on or make changes to this bug.