Bug 1803429 - [IPI][Baremetal] sometimes Mdns-publisher (infra pod) advertise node's name as 'localhost'
Summary: [IPI][Baremetal] sometimes Mdns-publisher (infra pod) advertise node's name a...
Keywords:
Status: CLOSED DUPLICATE of bug 1802675
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Yossi Boaron
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-16 06:55 UTC by Yossi Boaron
Modified: 2020-02-17 11:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-17 11:26:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yossi Boaron 2020-02-16 06:55:39 UTC
Description of problem:

The Mdns-publisher infra pod, reads host's hostname and advertise it using MDNS protocol. 

Sometimes the mdns-publisher advertise wrongly the hostname as 'localhost', the reason for that could be a race condition (mdns-publisher should start publishing only after node's name is != 'localhost' )

This bug is a duplication of https://bugzilla.redhat.com/show_bug.cgi?id=1790823 for release 4.3.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Antoni Segura Puimedon 2020-02-17 11:26:38 UTC

*** This bug has been marked as a duplicate of bug 1802675 ***


Note You need to log in before you can comment on or make changes to this bug.