Bug 180349 - Directory server crash upon language attributes emptying
Directory server crash upon language attributes emptying
Status: CLOSED DUPLICATE of bug 179810
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 10:03 EST by Thierry Lanfranchi
Modified: 2007-04-18 13:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 10:26:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thierry Lanfranchi 2006-02-07 10:03:29 EST
Description of problem: slapd process crashes after modifying language
attributes of inetOrgPerson object.


Version-Release number of selected component (if applicable):
Fedora Directory Server 1.0.1
using Sun JAVA 1.4.2_09
on up-to-date CentOs 4.2


How reproducible: Everytime


Steps to Reproduce:
1. open a user properties window in the console and choose the "languages" tab
2. Define French as the "Preference language"
3. add "First Name", "Last Name" and "Common Name" information for Afrikaans
language
4. Click OK to update the entry
5. Re-open the user properties and proceed to "languages" tab
6. Empty "First Name", "Last Name" and "Common Name" fields
7. Click OK to update the entry
  
Actual results:

- Console complains about not being able to contact the server:
"Cannot save to directory server
netscape.ldap.LDAPException: failed to connect to server
ldap://server.domain.local:389 (91); Cannot connect to the LDAP server"

- No slapd process in memory anymore, process crashed
following message on the users mailing list remained didn't get any answer :
https://www.redhat.com/archives/fedora-directory-users/2006-February/msg00024.html

Upon slapd process restart, server seems ok but the language informations have
not been deleted (despite what the log files say)

Expected results:
Empty fields for the removed language. Slapd process supposed to be still available.

Additional info:



Here are the last lines in the log before crash, with all log options turned on:
"
[02/Feb/2006:11:14:14 +0100] - Calling plugin 'Multimaster replication
bepreoperation plugin' #0 type 451
[02/Feb/2006:11:14:14 +0100] - => entry_apply_mods_wsi
[02/Feb/2006:11:14:14 +0100] -    delete: givenname;lang-af
[02/Feb/2006:11:14:14 +0100] - removing entire attribute givenname;lang-af
[02/Feb/2006:11:14:14 +0100] -    -
[02/Feb/2006:11:14:14 +0100] -    delete: sn;lang-af
[02/Feb/2006:11:14:14 +0100] - removing entire attribute sn;lang-af
[02/Feb/2006:11:14:14 +0100] -    -
[02/Feb/2006:11:14:14 +0100] -    delete: cn;lang-af
[02/Feb/2006:11:14:14 +0100] - removing entire attribute cn;lang-af
[02/Feb/2006:11:14:14 +0100] -    -
[02/Feb/2006:11:14:14 +0100] -    modifiersname:
uid=admin,ou=administrators,ou=topologymanagement,o=netscaperoot
[02/Feb/2006:11:14:14 +0100] -    replace: modifiersname
[02/Feb/2006:11:14:14 +0100] -    -
[02/Feb/2006:11:14:14 +0100] -    modifytimestamp: 20060202101411Z
[02/Feb/2006:11:14:14 +0100] -    replace: modifytimestamp
[02/Feb/2006:11:14:14 +0100] -    -
[02/Feb/2006:11:14:14 +0100] - <= entry_apply_mods_wsi 0
[02/Feb/2006:11:14:14 +0100] - => plugin_call_syntax_filter_ava uid=45123487
[02/Feb/2006:11:14:14 +0100] - <= plugin_call_syntax_filter_ava 0
[02/Feb/2006:11:14:14 +0100] - => id2entry_add( 14,
"uid=45123487,ou=utilisateurs,ou=infrastructure,dc=domain,dc=local" )
[02/Feb/2006:11:14:14 +0100] - -> attrcrypt_encrypt_entry
[02/Feb/2006:11:14:14 +0100] - <- attrcrypt_encrypt_entry
[02/Feb/2006:11:14:14 +0100] - <= id2entry_add 0
"
Comment 1 Rich Megginson 2006-02-14 10:26:44 EST

*** This bug has been marked as a duplicate of 179810 ***

Note You need to log in before you can comment on or make changes to this bug.