Bug 18037 - Intaller stopps, logfile missing
Summary: Intaller stopps, logfile missing
Status: CLOSED DUPLICATE of bug 13071
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-01 21:55 UTC by Need Real Name
Modified: 2007-04-18 16:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 21:43:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-01 21:55:31 UTC
I'm sorry parts of the "trace dump" are in Swedish. The installer stop's
just before start of upgrade. This is the message, saved to floppy:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1526, in
doInstall
    self.instLog = open(self.instLogName, "w+")
IOError: [Errno 2] Filen eller katalogen finns inte:
'/mnt/sysimage/tmp/upgrade.log'		#[Errno 2] File or catalog does not exist:

Local variables in innermost frame:
arch: i386
total: 120
msg: Filen existerar		#msg: File exists
logname: /tmp/upgrade.log
i: /etc/X11
p: zlib
l: [anacron, apmd, ash, at, authconfig, basesystem, bash, bc, bdflush,
bzip2, chkconfig, console-tools, cpio, cracklib, cracklib-dicts, crontabs,
cyrus-sasl, db1, db2, db3, dev, dhcpcd, diffutils, e2fsprogs, ed, eject,
file, filesystem, fileutils, findutils, gawk, gdbm, glib, glibc, gmp,
gnupg, gpm, grep, groff, gzip, hdparm, info, initscripts, isapnptools,
kbdconfig, kernel, kernel-pcmcia-cs, kernel-utils, krb5-libs, kudzu, less,
libstdc++, libtermcap, lilo, linuxconf, logrotate, losetup, mailcap, mailx,
MAKEDEV, man, mingetty, mkbootdisk, mkinitrd, mktemp, modutils, mount,
mouseconfig, ncompress, ncurses, net-tools, newt, ntsysv, openldap,
openssl, pam, passwd, pciutils, perl, popt, procmail, procps, psmisc, pump,
pwdb, quota, raidtools, readline, redhat-logos, redhat-release, rootfiles,
rpm, rpm-build, sash, sed, sendmail, setserial, setup, setuptool, sh-utils,
shadow-utils, slang, slocate, stat, sysklogd, SysVinit, tar, termcap,
textutils, time, timeconfig, tmpwatch, utempter, util-linux, vim-common,
vim-minimal, vixie-cron, which, words, zlib]
db: <rpmdb object at 85263d8>
self: <todo.ToDo instance at 84a15e8>
how: u
errno: 17
totalSize: 200264
f: <closed file '/mnt/sysimage/etc/mtab', mode 'w+' at 9002ba8>
ts: <rpmtrans object at 928a840>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2000-10-02 22:16:50 UTC
Does /tmp happen to be a symlink on the system you are upgrading?

Comment 2 Need Real Name 2000-10-04 16:24:55 UTC
Sorry for my late reply.

Yes, /tmp is a symlink.

I'll will alter it to an ordinary directory

/Mats

Comment 3 Need Real Name 2000-10-04 17:32:33 UTC
With /tmp as an ordinary directory all worked fine.

Thank's

Comment 4 Michael Fulbright 2000-10-06 21:42:58 UTC
We have a RFE to handle this better in the future, linking to it.

*** This bug has been marked as a duplicate of 13071 ***


Note You need to log in before you can comment on or make changes to this bug.