Bug 1803706 - Kernel 5.5.2 does not suspend on Dell XPS-13
Summary: Kernel 5.5.2 does not suspend on Dell XPS-13
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 31
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-17 09:48 UTC by Steven Bakker
Modified: 2020-03-09 15:39 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-09 15:39:56 UTC
Type: Bug


Attachments (Terms of Use)
kernel logs with three suspend/resume cycles: first one successful. (100.51 KB, text/plain)
2020-02-17 09:48 UTC, Steven Bakker
no flags Details

Description Steven Bakker 2020-02-17 09:48:24 UTC
Created attachment 1663479 [details]
kernel logs with three suspend/resume cycles: first one successful.

1. Please describe the problem:

Installed the 5.5.2 kernel for the Fedora Kernel Test Day and booted into it. After using it for some time, tried to suspend. First time works, subsequent attempts fail: system seems to power down for a second (screen goes dark, keyboard LEDs turn off), but then comes back on.

2. What is the Version-Release number of the kernel:

5.5.2-200.fc31.x86_64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Suspend worked fine up to and including 5.3.16-300.fc31.x86_64. After that (5.4 series) it has been hit and miss. I cannot say too much about the 5.4 series, since they exhibited bug #1780800, which made the whole 5.4 series unusable for me.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

   1. Boot into 5.5.2 kernel.
   2. Log in (GNOME desktop).
   3. Press power button to suspend. First attempt usually works.
   4. Resume.
   5. Press power button to suspend again. System powers down for a second, then comes back on.

When manually turning off Bluetooth before suspending, this problem does not seem to occur. I tried to automate this with systemd triggers, but I end up in a hit and miss situation (sometimes it works, often it doesn't). This makes me suspect a timing issue... By manually disabling Bluetooth, there's a delay between turning off Bluetooth and starting the suspend cycle. Could this be a clue?

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Not tested with rawhide.

6. Are you running any modules that not shipped with directly Fedora's kernel?:

No, only modules from kernel-core, kernel-modules, kernel-modules-extra

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Andrey Sitnik 2020-02-24 04:47:22 UTC
I have similar problem for Dell XPS 13 2-in-1 7390.

After updating to kernel 5.5 laptop can’t be switched off. On switching off or rebooting it freezes with black screen.

What I can’t provide to help locate the problem?

Comment 2 Justin M. Forbes 2020-03-03 16:37:33 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 31 kernel bugs.

Fedora 31 has now been rebased to 5.5.7-200.fc31.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 32, and are still experiencing this issue, please change the version to Fedora 32.

If you experience different issues, please open a new bug report for those.

Comment 3 Andrey Sitnik 2020-03-03 18:10:35 UTC
> If you have moved on to Fedora 32, and are still experiencing this issue, please change the version to Fedora 32.

I moved to Fedora 32 and still have this bug on 5.6.0-0.rc3.git0.1.fc32.x86_64

Comment 4 Steven Bakker 2020-03-09 11:02:34 UTC
It seems to have been fixed for me on kernel 5.5.7.

Will keep an eye on it.

Comment 5 Steven Bakker 2020-03-09 11:03:20 UTC
Sorry, forgot to clear the "needinfo".

Comment 6 Justin M. Forbes 2020-03-09 15:39:56 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.