Bug 1803736 - vSphere machine api controller should not run on 4.4
Summary: vSphere machine api controller should not run on 4.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Alberto
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks: 1811596
TreeView+ depends on / blocked
 
Reported: 2020-02-17 10:42 UTC by Alberto
Modified: 2020-05-15 16:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1811596 (view as bug list)
Environment:
Last Closed: 2020-05-15 16:09:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 492 0 None closed Bug 1803736: Revert "Vsphere provider" 2020-05-15 14:35:37 UTC

Description Alberto 2020-02-17 10:42:21 UTC
Description of problem:
vSphere IPI was dropped from 4.4, therefore we don't want the controller to run in this release. We'll enable it back once master opens for 4.5

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Milind Yadav 2020-03-09 07:47:35 UTC
Still seeing machine-api-controller pods 

[miyadav@miyadav bug1800425]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-03-08-235004   True        False         132m    Cluster version is 4.4.0-0.nightly-2020-03-08-235004
[miyadav@miyadav bug1800425]$

Steps :

oc get pods -n openshift-machine-api

NAME                                           READY   STATUS    RESTARTS   AGE
cluster-autoscaler-operator-7dd5b454f7-bdgkq   2/2     Running   0          136m
machine-api-controllers-6bbd74ddd-6lr8r        4/4     Running   4          144m
machine-api-operator-7969bfb45f-8sblt          2/2     Running   2          165m

Actual : machine-api-controllers running
Expected : machine-api-controller pods should not be deployed for this version

Comment 5 Milind Yadav 2020-03-23 10:03:18 UTC
As it was expected that controller should run on 4.5 we are seeing that 

[miyadav@miyadav ManualRun]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-03-22-211241   True        False         22m     Cluster version is 4.5.0-0.nightly-2020-03-22-211241

Steps :

run oc get pods -n openshift-machine-api 

NAME                                           READY   STATUS    RESTARTS   AGE
cluster-autoscaler-operator-74c6c6dbf8-f7wrt   2/2     Running   0          34m
machine-api-controllers-6f9968fcf5-r82ck       4/4     Running   0          35m
machine-api-operator-56bdfb8474-ll2ll          2/2     Running   0          35m

Actual -
Machine controller pod is running

Expected :
Machine controller pod is running


Note You need to log in before you can comment on or make changes to this bug.