Bug 1803739 - Improve NodeControllerDegraded condition messages
Summary: Improve NodeControllerDegraded condition messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Michal Fojtik
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1774212 1803742 1803744 1809296
TreeView+ depends on / blocked
 
Reported: 2020-02-17 10:53 UTC by Michal Fojtik
Modified: 2020-05-13 21:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Improve NodeControllerDegraded operator condition messages to include the proper reason why the nodes are considered not ready. Reason: In past, when the node controller see unready node, it only reports that fact, without giving any details of why they are degraded. Result: With this change, the detailed message is include per node, describing the reason why are they degraded (networking, disk pressure, etc.)
Clone Of:
: 1803742 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:58:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:58:14 UTC

Description Michal Fojtik 2020-02-17 10:53:22 UTC
Description of problem:

We see a lot of clusters via Telemetry reporting static pod operators degraded with reason: "NodeControllerDegraded: The master node(s) "name" not ready".

This condition prevents rolling upgrades for those clusters and further debugging is required to determine the real reason of why the masters are not ready.

In 4.4, we merged https://github.com/openshift/library-go/pull/660 that fixes this message to include last transition time, reason and message directly from the Node object. This message is now reported instead of just "not ready".


Steps to Reproduce:
1. Make "master" node report NotReady
2. Wait for the NodeControllerDegraded condition to appear for the operator
3. Check the message to now include detailed reason.

Actual results:


Expected results:


Additional info:

Comment 7 errata-xmlrpc 2020-05-13 21:58:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.