Bug 1803766 - Remove glog package in favor of klog
Summary: Remove glog package in favor of klog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Alexander Demicev
QA Contact: Milind Yadav
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-17 11:47 UTC by Alexander Demicev
Modified: 2020-08-27 22:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-27 22:34:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-aws pull 290 0 None closed Bug 1803766: Remove glog package in favor of klog 2020-09-16 06:31:14 UTC

Description Alexander Demicev 2020-02-17 11:47:48 UTC
Description of problem:
We are using 2 different logging libraries for no reason. One of them should be removed


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Milind Yadav 2020-03-11 06:38:51 UTC
Steps 

Validated few logs printed on console , seems good .

[miyadav@miyadav bugs1104]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-03-10-204444   True        False         62m     Cluster version is 4.5.0-0.nightly-2020-03-10-204444
[miyadav@miyadav bugs1104]$ 
Some commands ran to validate :

oc logs -f cluster-autoscaler-operator-d979c885c-mrvc7 -c cluster-autoscaler-operator 

oc logs -f machine-api-controllers-64f5d7dfc-pwff8 -c machine-controller 

Actual : logs worked as expected
Expected : logs printed

Comment 4 Luke Meyer 2020-08-27 22:34:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409'


Note You need to log in before you can comment on or make changes to this bug.