Bug 1803780 - Disk interfaces of created VMs should present errors or warnings if they aren't valid or recommended
Summary: Disk interfaces of created VMs should present errors or warnings if they aren...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Ido Rosenzwig
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1809936
TreeView+ depends on / blocked
 
Reported: 2020-02-17 12:53 UTC by Ido Rosenzwig
Modified: 2020-08-04 18:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Add warning and error messages in VM disk details for disks with an invalid or not-recommended bus type.
Clone Of:
: 1809936 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:00:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4600 None closed Bug 1803780: Validate disk buses on created VMs 2020-09-09 16:09:18 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:00:45 UTC

Description Ido Rosenzwig 2020-02-17 12:53:27 UTC
Description of problem:
on the `Disks` tab on a created VM details view, disk interface errors and warnings should appear like in the wizard.

If a VM is configured to use a disk with invalid or not recommended bus type the user should be warned.


Version-Release number of selected component (if applicable):
4.3

How reproducible:
100%

Steps to Reproduce:
1. Create a VM using the wizard with 'Windows' OS and 'url' or 'container' source
   In the storage tab verify you cannot pick 'scsi' as the interface
2. Go to the 'Virtual Machines' tab and click the VM you just created.
3. go to the Disks tab
4. Edit the root disk 
5. 'scsi' option is available for the interface although it is not allowed.
6. If you pick SATA no warning message is presented although it's not recommended bus type

Actual results:
Non-valid bus type can be picked in modal when editing or adding disk
No errors or warning appear in the modal or the disks table in the disks tab

Expected results:
Only valid and not recommended bus types can be picked in the modal when editing or adding disk
Errors and warnings should be visible if there is a problem.


Additional info:
The user can always use invalid disks if he will edit the VM yaml manually using the YAML tab, as we don't want to prevent the user completely from using what he wants.

Comment 3 Guohua Ouyang 2020-03-31 06:41:50 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016, scsi is not available in vm disk tab, and a warning shows when selecting sata.

Comment 5 errata-xmlrpc 2020-08-04 18:00:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.