Bug 1803857 - VM Details and Overview pages keep showing IP address after VM has been stopped
Summary: VM Details and Overview pages keep showing IP address after VM has been stopped
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1807023
TreeView+ depends on / blocked
 
Reported: 2020-02-17 15:43 UTC by Radim Hrazdil
Modified: 2020-08-04 18:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1807023 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:00:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (145.87 KB, image/png)
2020-02-17 15:43 UTC, Radim Hrazdil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4368 0 None closed Bug 1803857: do not show ip if no launcher pod exist 2020-06-23 08:33:18 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-08-04 18:00:46 UTC

Description Radim Hrazdil 2020-02-17 15:43:22 UTC
Created attachment 1663563 [details]
screenshot

Description of problem:
When a VM is stopped, the Details and Overview pages keep displaying IP address. Instead, there should be 'Not Available'.


Version-Release number of selected component (if applicable):
4.4

How reproducible:
100

Steps to Reproduce:
1. Start a VM
2. Stop a VM
3.

Actual results:
IP address is still displayed

Expected results:
IP address should not be displayed after stopping a VM

Additional info:

Comment 3 Guohua Ouyang 2020-02-24 03:01:36 UTC
verified on 4.4.0-0.nightly-2020-02-22-102956.

Comment 4 Yaacov Zamir 2020-04-30 08:39:59 UTC
docs do not change after bug fix

Comment 6 errata-xmlrpc 2020-08-04 18:00:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.