Bug 1803867 - When a node is unassigned from an application in the edit flow, the change is not applied
Summary: When a node is unassigned from an application in the edit flow, the change is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Debsmita Santra
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1806652
TreeView+ depends on / blocked
 
Reported: 2020-02-17 15:50 UTC by Debsmita Santra
Modified: 2020-08-04 18:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806652 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:00:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
removal from application (173.92 KB, image/png)
2020-03-24 07:34 UTC, Gajanan More
no flags Details
Changes applied (191.78 KB, image/png)
2020-03-24 07:35 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4318 0 None closed Bug 1803867: apply the change when node is unassigned from an application 2020-06-23 08:33:21 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-08-04 18:12:55 UTC

Description Debsmita Santra 2020-02-17 15:50:09 UTC
Description of problem:
In the edit flow when the node is unassigned from an application group, the change is not applied and the node continues to remain in the application group.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Right-click on a topology node, which is in an application group, to edit
2. In the General Section of the Import form, change the application to `Unassigned`
3. Click on Submit

Actual results:
The workload continues to remain in the application group

Expected results:
The workload should be removed from the application group

Additional info:

Comment 4 Gajanan More 2020-03-24 07:34:06 UTC
I have validated this bug on
Build:4.5.0-0.nightly-2020-03-23-235404
Browser: Google Chrome Version 78.0.3904.108
Marking this bug verified.
Please have a look at the shared screenshot.

Comment 5 Gajanan More 2020-03-24 07:34:47 UTC
Created attachment 1672931 [details]
removal from application

Comment 6 Gajanan More 2020-03-24 07:35:53 UTC
Created attachment 1672938 [details]
Changes applied

Comment 8 errata-xmlrpc 2020-08-04 18:00:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.