Bug 180390 - rhn_check crashing when installing updates
rhn_check crashing when installing updates
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Orazi
Brandon Perkins
Depends On:
  Show dependency treegraph
Reported: 2006-02-07 14:24 EST by Razvan Corneliu C.R. VILT
Modified: 2008-04-18 17:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-18 17:56:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Razvan Corneliu C.R. VILT 2006-02-07 14:24:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20060111 Firefox/

Description of problem:
After noticing that my server is out of sync, I've tried the manual rhn_check. The error doesn't give me any clue as to the cause of the error. I will try installing the updates manually to see if the problem can be reproduced with other packages.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. select some updates in rhn.redhat.com to be installed on the target system.
2. run rhn_check or rhn_check -v.

Actual Results:  I received an error:

ypbind                                  1.17.2         8
No advisory information available

ypserv                                  2.13           9
No advisory information available

  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 353, in update
    ret = _catchErrors(batchRun, "packages.update", (0, pkgList))
  File "/usr/share/rhn/actions/packages.py", line 189, in _catchErro
    ret = apply(method, args)
  File "/usr/share/rhn/actions/packages.py", line 390, in batchRun
    actionPkgs = pkgList)
  File "/usr/share/rhn/up2date_client/wrapper.py", line 1137, in bat
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 78, in
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 163, in
  File "/usr/share/rhn/up2date_client/up2date.py", line 386, in dryR
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 750, in so
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 644, in pr
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 411, in __
    added = self.__add(solved, check = 1)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 232, in __
    hdr = headerList[p]
  File "/usr/share/rhn/up2date_client/headers.py", line 34, in __get
    if self._cache.has_key(itemtuple):
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 117, in ha
    return self.__cache.has_key(item)
TypeError: list objects are unhashable

Expected Results:  The updates downloaded and installed.

Additional info:

I even tried setting up2date to just-download the updates and am still getting the same error after the package list. I am using a proxy server without authentication.
Comment 1 Red Hat Bugzilla 2007-04-11 20:30:26 EDT
User bnackash@redhat.com's account has been closed
Comment 2 Razvan Corneliu C.R. VILT 2007-10-31 08:07:56 EDT
The problem solved itself a long time ago. I think that this bug is irelevant,
and I sugest closing it.
Keep Bugzilla clean!!!
Comment 3 Mike Orazi 2008-04-18 17:57:15 EDT
Will do.

Note You need to log in before you can comment on or make changes to this bug.