Bug 180391 - "Failed to open included config file /etc/modprobe.conf.dist: No such file or directory"
Summary: "Failed to open included config file /etc/modprobe.conf.dist: No such file or...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: module-init-tools   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-07 19:41 UTC by Jordan Russell
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 20:46:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jordan Russell 2006-02-07 19:41:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727)

Description of problem:
It appears that in the latest errata release of module-init-tools (3.2-0.pre9.0.FC4.1), modprobe.conf.dist has moved from /etc to /etc/modprobe.d. However, modprobe.conf still references /etc/modprobe.conf.dist:

include /etc/modprobe.conf.dist

This results in the following message every time modprobe is run:

WARNING: Failed to open included config file /etc/modprobe.conf.dist: No such file or directory

I see this on every machine on which the errata package has been installed.

Version-Release number of selected component (if applicable):
module-init-tools-3.2-0.pre9.0.FC4.1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to module-init-tools-3.2-0.pre9.0.FC4.1 on an existing FC4 system.
2. Run "modprobe xxx"

Actual Results:  WARNING: Failed to open included config file /etc/modprobe.conf.dist: No such file or directory

Expected Results:  The package upgrade process should have updated the path in modprobe.conf (?).

Additional info:

Comment 1 Jordan Russell 2006-02-07 20:46:50 UTC
Hmm, it looks like the "include" line may have actually been left over from a 
previous version of FC.


* Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 2.4.26-6
...
- always include /etc/modprobe.conf.dist (don't require the line in 
modprobe.conf)


So it seems I should just remove it. Closing.


Note You need to log in before you can comment on or make changes to this bug.