Bug 1803961 - missing toolbar icons in qcad
Summary: missing toolbar icons in qcad
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qcad
Version: 31
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio T. (sagitter)
QA Contact: Fedora Extras Quality Assurance
URL: https://www.qcad.org/rsforum/viewtopi...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-17 20:05 UTC by Pontus Enhager
Modified: 2020-03-16 20:32 UTC (History)
2 users (show)

Fixed In Version: qcad-3.24.2.6-2.fc31 qcad-3.24.2.6-2.fc30 qcad-3.24.2.6-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-12 21:55:52 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of situation (99.23 KB, image/png)
2020-02-17 20:05 UTC, Pontus Enhager
no flags Details

Description Pontus Enhager 2020-02-17 20:05:49 UTC
Created attachment 1663584 [details]
screenshot of situation

Description of problem:
not all icons are visible, they are clickable and if clicked, a grey square appears. Hoovering over wher the oicon should be gives a text icon hint.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.start to draw
2.try to export to pdf or print preview etc....
3.

Actual results:
difficult to handle

Expected results:
nice icons explaining what they do

Additional info:

Comment 1 Pontus Enhager 2020-02-19 18:14:41 UTC
valid for qcad-3.24.2.1-3.fc31.x86_64

Comment 2 Pontus Enhager 2020-02-29 09:30:01 UTC
Installing rawhide version 

qcad-3.24.2.6-1.fc32.x86_64 does NOT work
qcad-3.21.3.15-1.fc30.x86_64 WORKS! 
qcad-3.22.1.0-7.fc31.x86_64 does NOT work

is aywhere i can find the versions in between to be able to bisect where things go wrong ?

Comment 3 Pontus Enhager 2020-02-29 09:31:57 UTC
(even) older commercial releases downloaded directly from upstream seems to work as well (but my license has ran out so no more updates...)

Comment 4 Pontus Enhager 2020-02-29 12:02:28 UTC
qcad-3.22.1.0-4.fc30.x86_64.rpm and qcad-3.22.1.0-1.fc30.x86_64.rpm has the issue in https://bugzilla.redhat.com/show_bug.cgi?id=1790550 and mitigating that with exporting QT_QPA_PLATFORM=xcb - the fault is still present

so i presume something happened between 3.22 & 3.21 OR by means of some underlying library that i lack the knowledge to analyse properly without instructions....


(possibly needles to say qcad-3.24.2.6-1.fc33.x86_64 does NOT work either)

Comment 5 Pontus Enhager 2020-02-29 13:54:54 UTC
when running qcad from terminal window i get this: "Warning:  RPropertyTypeId::generateId: property already initialized:  7RObject : "" : "Invisible"" right after startup i do not know if this is relevant...

Comment 6 Pontus Enhager 2020-03-02 18:22:32 UTC
it seems as in between 3.21 and 3.22 there is a move from qt4 to qt5 and some unbundling of libraries going on, however I do not have the knowledge to be able to say that this is the root cause

Comment 7 Antonio T. (sagitter) 2020-03-02 18:49:38 UTC
Maybe it's a packaging bug. I'm building a new release.

Comment 8 Pontus Enhager 2020-03-02 19:10:16 UTC
i rebuilt qcad-3.24.2.6-1.fc31.x86_64.rpm on my computer - that did not help my problem (but i did sort of not expect that either given my limited knowledge) eagerly awaiting a new test build from you :)

Comment 9 Pontus Enhager 2020-03-02 21:45:35 UTC
this version (qcad-3.24.2.6-2.fc33) seems to work for me in F31! https://bodhi.fedoraproject.org/updates/FEDORA-2020-7fd05eae1d

Comment 10 Fedora Update System 2020-03-03 11:53:53 UTC
FEDORA-2020-9af5b9dee3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9af5b9dee3

Comment 11 Fedora Update System 2020-03-03 11:53:54 UTC
FEDORA-2020-7e164d5b11 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7e164d5b11

Comment 12 Fedora Update System 2020-03-03 11:53:55 UTC
FEDORA-2020-aad67ed616 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-aad67ed616

Comment 13 Fedora Update System 2020-03-03 16:10:27 UTC
qcad-3.24.2.6-2.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-aad67ed616

Comment 14 Fedora Update System 2020-03-03 20:28:24 UTC
qcad-3.24.2.6-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9af5b9dee3

Comment 15 Fedora Update System 2020-03-03 20:46:40 UTC
qcad-3.24.2.6-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7e164d5b11

Comment 16 Fedora Update System 2020-03-12 21:55:52 UTC
qcad-3.24.2.6-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2020-03-12 22:13:01 UTC
qcad-3.24.2.6-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2020-03-13 02:30:04 UTC
qcad-3.24.2.6-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2020-03-16 20:20:28 UTC
qcad-3.24.2.6-2.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2020-03-16 20:32:03 UTC
qcad-3.24.2.6-2.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.