Bug 1803970 - Image registry failing to start on baremetal IPI
Summary: Image registry failing to start on baremetal IPI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.0
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-17 20:54 UTC by Stephen Benjamin
Modified: 2020-05-18 08:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:58:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 460 None closed Bug 1803970: Creating ClusterOperator resource on ErrStorageNotConfigured 2020-05-27 14:49:56 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:58:22 UTC

Description Stephen Benjamin 2020-02-17 20:54:24 UTC
Description of problem:

Registry is not available on baremetal IPI.  The installer is stuck waiting on image-registry:

> level=info msg="Waiting up to 1h0m0s for the cluster at https://api.ostest.test.metalkube.org:6443 to initialize..."
> level=debug msg="Still waiting for the cluster to initialize: Cluster operator > image-registry has not yet reported success"
> level=debug msg="Still waiting for the cluster to initialize: Cluster operator > image-registry has not yet reported success"

The logs for image-registry operator say this:

> E0217 20:34:34.936684      12 clusteroperator.go:94] unable to sync ClusterOperatorStatusController: storage backend not configured, requeuing
> E0217 20:34:34.936831      12 controller.go:353] unable to sync: unable to get generators: storage backend not configured, requeuing


Version-Release number of selected component (if applicable):

4.4.0-0.ci-2020-02-17-143917

How reproducible:

Always

Comment 1 Stephen Benjamin 2020-02-17 20:55:28 UTC
There may also be a secondary bug, related to this. If image-registry fails to start, the clusteroperator never gets reported.  `oc get clusteroperators` is not showing image-registry at all.

Comment 4 Udi 2020-02-19 07:49:54 UTC
In IPI installations, the registry is initially in "Removed" state. This is by design, until the user sets up persistent storage for it: https://docs.openshift.com/container-platform/4.3/registry/configuring_registry_storage/configuring-registry-storage-baremetal.html

Comment 6 errata-xmlrpc 2020-05-13 21:58:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.