Bug 180403 - Can't resize a window using the mouse if some part of it is underneath top gnome panel
Summary: Can't resize a window using the mouse if some part of it is underneath top gn...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-07 21:09 UTC by Mathieu Chouquet-Stringer
Modified: 2014-06-18 09:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 15:15:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mathieu Chouquet-Stringer 2006-02-07 21:09:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
If you drag a non-maximized window and make its upper part "disappear" underneath the top gnome panel, you won't be able to resize it by using the left mouse button on the window borders.

If you left click on any of the borders, you'll get the window system menu (that icon in the upper left corner of a decorated window) instead of the standard resize tool.

Note that it doesn't happen with the lower panel. So I would guess it has something to do with the title bar/system menu being underneath the panel

Version-Release number of selected component (if applicable):
metacity-2.13.55-1

How reproducible:
Always

Steps to Reproduce:
1. Move part of non-maximized window underneath the upper gnome panel
2. Try to resize it using the mouse
3. You get the system menu
  

Expected Results:  Should have been able to resize the window

Additional info:

Comment 1 Rahul Sundaram 2006-02-20 11:05:52 UTC

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Comment 2 Mathieu Chouquet-Stringer 2006-02-22 09:53:34 UTC
Bug still present in FC5T3 (metacity-2.13.89.0.2006.02.17-2)

Comment 3 Søren Sandmann Pedersen 2006-04-20 15:15:33 UTC
Well, this is the way upstream metacity behaves. Personally, I agree with you
and think it's the wrong behavior, but I am not going to patch around this issue
in Fedora. 

Feel free to report this problem in GNOME bugzilla (http://bugzilla.gnome.org).



Note You need to log in before you can comment on or make changes to this bug.