Bug 1804075 - unable to report bug during installation
Summary: unable to report bug during installation
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: ekulik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2020-02-18 07:49 UTC by lnie
Modified: 2020-02-19 09:55 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-18 10:30:29 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
screenshot (127.10 KB, image/png)
2020-02-18 07:49 UTC, lnie
no flags Details
anaconda.log (67.09 KB, text/plain)
2020-02-18 07:58 UTC, lnie
no flags Details
screenshot (104.26 KB, image/png)
2020-02-18 09:15 UTC, lnie
no flags Details

Description lnie 2020-02-18 07:49:34 UTC
Created attachment 1663661 [details]
screenshot

Description of problem:

Try to report a crash bug during installation,by clicking "report bug" button,
the report process will end up with an error as shown in the attached screenshot.


Version-Release number of selected component (if applicable):
abrt-2.14.0-2.fc32.x86_64.rpm   
Fedora-Server-dvd-x86_64-32-20200217.n.0.iso 
workstation is also affected 

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 ekulik 2020-02-18 07:50:54 UTC
The message in the screenshot is cut off…

Comment 2 lnie 2020-02-18 07:58:17 UTC
Created attachment 1663663 [details]
anaconda.log

Comment 3 Fedora Blocker Bugs Application 2020-02-18 08:00:30 UTC
Proposed as a Blocker for 32-beta by Fedora user lnie using the blocker tracking app because:

 This affects:
The installer must be able to report failures to Bugzilla, with appropriate information included.

Comment 4 ekulik 2020-02-18 08:01:17 UTC
Is there anything related in the log file? I can’t see anything.

Comment 5 ekulik 2020-02-18 08:05:18 UTC
And how are you reproducing the issue?

Comment 6 lnie 2020-02-18 09:13:42 UTC
Ah,I thought there might be some useful message in the log.Just noted the bug is reported successfully,but only anaconda-tb is uploaded,https://bugzilla.redhat.com/show_bug.cgi?id=1804066
I tried to create a crash with kill -USR1 `cat /var/run/anaconda.pid` three times( I thought it can be simply reproduced by kill ... ,turns out this reproducer is trickey),and the last time,I reproduced the bug successfully, it seems that you need kill it during anaconda do the storage partition.
The reproducer is:
try to create an software raid partition,and the bug happens during installation process #1804080

Comment 7 lnie 2020-02-18 09:15:14 UTC
Created attachment 1663709 [details]
screenshot

Comment 8 ekulik 2020-02-18 10:25:34 UTC
Able to reproduce, but the reporter seems to work (although it could be because it was detected as duplicate and therefore a new bug was not created).

Comment 9 ekulik 2020-02-18 10:30:29 UTC
Creating a new bug also worked: https://bugzilla.redhat.com/show_bug.cgi?id=1804150

Both of your screenshots obscure the potentially-useful information (text not being wrapped in the first one and log not being expanded in the second one), so I’m going to treat this as an issue on your end.

Feel free to reopen if you have something actionable.


Note You need to log in before you can comment on or make changes to this bug.