Bug 18041 - 3com ethernet module problem
Summary: 3com ethernet module problem
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dale Lovelace
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-01 22:47 UTC by aging_tamarin
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-01 21:20:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script of '/sbin/modprobe 3c509' and 'dmesg' (3.42 KB, text/plain)
2000-10-03 03:55 UTC, aging_tamarin
no flags Details
ifcfg script (357 bytes, text/plain)
2000-11-02 22:36 UTC, aging_tamarin
no flags Details

Description aging_tamarin 2000-10-01 22:47:52 UTC
3c509.o worked in redhat 6.1 configured from linuxconf. insmod 3c509 eth0 
fail upon startup for redhat 6.2 and 7.0.

Comment 1 Alan Cox 2000-10-01 22:57:00 UTC
What happens when you do the insmod 3c509 ? Is anything logged in dmesg ?


Comment 2 aging_tamarin 2000-10-01 23:03:40 UTC
at startup
when it try to bring up eth0 
error: delaying initialization fail

Comment 3 aging_tamarin 2000-10-01 23:33:41 UTC
at redhat 6.2, 7.0 startup 
when it try to bring up eth0 
error: relaying initialization fail
-------------------------------------------
I used to configure ethernet from linuxconf. 
setting for my 3c09 card would be like 
Net device:eth0
Kernel module: 3c509.o
I/O port: 0x300
Irq:10
Net device:eth1    //second ethernet card
Kernel module: tulip.o  //both ethernet cards work fine
-------------------------------------
For redhat 6.2, 7.0, I configure ethernet from linuxconf. 
Net device:eth0
Kernel module: 3c509  // either 3c509 or 3c509.o can't insmod at startup
I/O port: 0x300        
Irq:10
Net device:eth1    //second ethernet card
Kernel module: tulip  //tulip ethernet card works without .o at the end. 
doesn't work if it's tulip.o
-------------------------------------




Comment 4 Nalin Dahyabhai 2000-10-02 05:47:00 UTC
What are the contents of /etc/modules.conf?  If it includes "alias eth0 3c509",
then this may in fact be a kernel-related bug.

Comment 5 aging_tamarin 2000-10-02 05:58:32 UTC
-------content of /etc/modules.conf --------
alias parport_lowlevel parport_pc
alias eth0 3c509
options 3c509 io=3X100 irc=10
--------end of content---------------------

Comment 6 Nalin Dahyabhai 2000-10-02 06:10:18 UTC
It looks like that file's been written wrong.  This line:
options 3c509 io=3X100 irc=10
should probably be:
options 3c509 io=0x300 irq=10

Comment 7 aging_tamarin 2000-10-02 06:16:14 UTC
Ops, I typed it wrong. Sorry about that.
-------content of /etc/modules.conf --------
alias parport_lowlevel parport_pc
alias eth0 3c509
options 3c509 io=0x300 irq=10
--------end of content---------------------

Comment 8 Alan Cox 2000-10-02 08:52:47 UTC
Type '/sbin/modprobe 3c509' then 'dmesg' and attach the dmesg output please


Comment 9 Michael Fulbright 2000-10-02 22:16:01 UTC
Switching to appropriate component for the installer (anaconda), but not sure
this is an anaconda issue yet.

Comment 10 aging_tamarin 2000-10-03 03:55:55 UTC
Created attachment 3641 [details]
script of '/sbin/modprobe 3c509' and 'dmesg'

Comment 11 Michael Fulbright 2000-11-01 20:59:10 UTC
Assigning to test engineer to replicate.

Comment 12 Brock Organ 2000-11-01 21:19:58 UTC
reassigning these to dale@redhat.com for further review ...

Comment 13 Dale Lovelace 2000-11-02 19:31:46 UTC
Could you please include the contents of
/etc/sysconfig/network-scripts/ifcfg-eth0 ? You may do this at the command line
by typing "cat /etc/sysconfig/network-scripts/ifcfg-eth0 > filename" then
attaching that file (filename) to this bug report. Thanks!

Comment 14 aging_tamarin 2000-11-02 22:36:54 UTC
Created attachment 4954 [details]
ifcfg script


Note You need to log in before you can comment on or make changes to this bug.