Bug 1804107 - StorageClassName:Null shows up in StorageCluster.yaml for OCP 4.3 + OCS 4.2.1
Summary: StorageClassName:Null shows up in StorageCluster.yaml for OCP 4.3 + OCS 4.2.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: afrahman
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks: 1812448 1812907
TreeView+ depends on / blocked
 
Reported: 2020-02-18 08:58 UTC by Neha Berry
Modified: 2020-07-13 17:16 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: DOM rendering was getting uncontrolled and not handling the states in a correct manner for the storage class dropdown. Consequence: On initial render, the state of dropdown is getting cleared and set to null Fix: Controlled unnecessary updates on UI to set the state properly. Result: Storage class in not null
Clone Of:
: 1812907 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:15:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4676 0 None closed Bug 1804107: Mount OCS form when csv is available 2020-07-07 02:52:04 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:16:10 UTC

Comment 9 Michael Adam 2020-03-04 22:23:17 UTC
This is approved for OCS 4.3.0.

Is there a patch? In which component? ... :-)

Comment 10 Ankush Behl 2020-03-05 12:31:41 UTC
Michael, We are working on it the fix that is required in UI.
The component is not behaving expectedly for the dropdown of storage class selection. 

Needs some more investigation.

Comment 11 Michael Adam 2020-03-05 15:19:24 UTC
Since this is a patch in openshift, not sure what we can do here for 4.3 tracking.

@Elad, what do you suggest: move it out?
Or keep it here for verification if we get an OCP z-stream update with the fix in time for OCS 4.3 GA?

Comment 12 afrahman 2020-03-06 11:08:54 UTC
The issue is caused due to the different

Comment 13 Nishanth Thomas 2020-03-06 12:54:57 UTC
(In reply to Michael Adam from comment #11)
> Since this is a patch in openshift, not sure what we can do here for 4.3
> tracking.
> 
> @Elad, what do you suggest: move it out?
> Or keep it here for verification if we get an OCP z-stream update with the
> fix in time for OCS 4.3 GA?

Let us wait until we get an OCP z-stream update with the fix in.  we will try push and get this in asap

Comment 14 afrahman 2020-03-07 07:10:57 UTC
(In reply to afrahman from comment #12)
> The issue is caused due to the different


I just checked , this comment got added by mistake.
Please ignore

Comment 15 Neha Berry 2020-03-13 05:25:54 UTC
@afreen,

Please provide the nightly build detail for OCP 4.5 and we can start the verification process


Since this is an OCP bug, will it be ok to test with GA'd OCS 4.2.2 or do we need internal rc builds of 4.2/4.3 ?

Comment 16 afrahman 2020-03-13 05:32:45 UTC
This build has the fix https://openshift-release.svc.ci.openshift.org/releasestream/4.5.0-0.nightly/release/4.5.0-0.nightly-2020-03-12-153508.
Any build after this will also work.

Yes it can be tested with any OCS version.

This bug is visible on all OCP versions (sometimes it is not as its a technical glitch).   

Thanks

Comment 18 afrahman 2020-03-16 11:16:59 UTC
I verified this bug on OCP stable-4.5 with OCS 4.2
Hence moving the bug to verified state.

Comment 21 errata-xmlrpc 2020-07-13 17:15:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.