Bug 1804143 - Monitoring Dashboards: bar chart links returns empty query
Summary: Monitoring Dashboards: bar chart links returns empty query
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Pickering
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks: 1806815
TreeView+ depends on / blocked
 
Reported: 2020-02-18 10:22 UTC by Yadan Pei
Modified: 2020-07-13 17:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806815 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:15:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4454 0 None closed Bug 1804143: Monitoring Dashboards: Remove broken bar chart links & clean up 2020-06-23 08:33:46 UTC
Github openshift console pull 4494 0 None closed Bug 1804143: Graphs: Change `Bar` component's `isLink` to `noLink` 2020-06-23 08:33:46 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:16:10 UTC

Description Yadan Pei 2020-02-18 10:22:43 UTC
Description of problem:
Currently we enabled clicking on bar charts data, but clicking them will return empty query, while in Grafana console data in bar charts is not clickable

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-17-211020

How reproducible:


Steps to Reproduce:
1. View 'cluster-total' dashboard on Monitoring -> Dashboards page
2. click on any link in one of the bar chart, eg `Current Rate of Bytes Received` bar chart


Actual results:
2. User is taken to Monitoring -> Metrics page monitoring/query-browser?query0= but no query is given, No Query Entered

Expected results:
2. If we decide to include click on links in chart, it should give correct query params, in Grafana console clicking is disabled on bar charts 

Additional info:

Comment 1 Samuel Padgett 2020-02-26 13:33:39 UTC
Moving back to assigned for follow on PR https://github.com/openshift/console/pull/4494

Comment 4 Yanping Zhang 2020-02-28 09:27:03 UTC
Checked on OCP 4.5 with payload 4.5.0-0.ci-2020-02-28-043432, now the data bar on Kubernete/Networking/Cluster dashboard is not clickable.
The bug is fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2020-07-13 17:15:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.