Bug 1804167 - Cannot modify OVS system interface connection profile
Summary: Cannot modify OVS system interface connection profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.2
Assignee: Thomas Haller
QA Contact: Desktop QE
URL:
Whiteboard:
: 1804561 (view as bug list)
Depends On:
Blocks: nmstate-nm
TreeView+ depends on / blocked
 
Reported: 2020-02-18 11:35 UTC by Gris Ge
Modified: 2020-04-28 16:54 UTC (History)
11 users (show)

Fixed In Version: NetworkManager-1.22.8-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:14 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Reproduce script (665 bytes, application/x-shellscript)
2020-02-18 11:35 UTC, Gris Ge
no flags Details
System logs with NM trace enabled (473.32 KB, text/plain)
2020-02-18 11:37 UTC, Gris Ge
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github nmstate nmstate issues 809 0 None open Cannot detach OVS system interface from OVS bridge 2020-03-10 18:05:03 UTC
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:36 UTC

Description Gris Ge 2020-02-18 11:35:10 UTC
Created attachment 1663737 [details]
Reproduce script

Description of problem:

Try to detach 'eth1' from a OVS bridge. but `nmcli edit` silently ignored
all changes made to `connection.master`, `connection.slave-type` and `ovs-interface.type`.

Version-Release number of selected component (if applicable):
NetworkManager-1.22.7-24704.53b878818c.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. ./nm_bug.sh
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Gris Ge 2020-02-18 11:37:41 UTC
Created attachment 1663738 [details]
System logs with NM trace enabled

Comment 2 Beniamino Galvani 2020-02-18 15:10:28 UTC
The issue here is that the ifcfg-rh backend doesn't remove the OVS_PORT=port0 variable from the connection during the update.

This is fixed on master by commit "ifcfg-rh: clear all untouched, known keys before writing ifcfg-rh file":

 https://gitlab.freedesktop.org/NetworkManager/NetworkManager/commit/07262b165d411456680be062df5f74b43d921dca

Comment 3 Thomas Haller 2020-02-18 17:40:29 UTC
fixed on nm-1-22 branch:

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/commit/0c8046574e782ca926d265348d10866f1653aef1


(also, a simpler reproducer in the commit message).


@QA: I think this is a very trivial fix. I don't think it's worth writing a CI test. Manual testing should suffice.

Comment 4 Gris Ge 2020-02-19 06:57:35 UTC
Thanks for the quick fix. It works well.

Comment 7 Till Maas 2020-02-21 08:30:30 UTC
*** Bug 1804561 has been marked as a duplicate of this bug. ***

Comment 8 Vladimir Benes 2020-02-25 14:31:19 UTC
test clear_ovs_settings added

Comment 10 errata-xmlrpc 2020-04-28 16:54:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.