Bug 180417 - CJKI text installation should be in english
CJKI text installation should be in english
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: i18n, Reopened
Depends On:
Blocks: 171491 FC6Blocker 202738
  Show dependency treegraph
 
Reported: 2006-02-07 19:49 EST by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-11.1.0.84-1.i386.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 01:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of anaconda stage 2 with Traditoinal Chinese selected (59.24 KB, image/png)
2006-02-07 19:50 EST, Lawrence Lim
no flags Details
Message box showing that CJKI is not avaiable for stage 2 (14.50 KB, image/jpeg)
2006-08-22 03:20 EDT, A S Alam
no flags Details
Next page after warning (126.94 KB, image/jpeg)
2006-08-22 03:24 EDT, A S Alam
no flags Details

  None (edit)
Description Lawrence Lim 2006-02-07 19:49:03 EST
Description of problem:
Selecting any of the CJK language for installation has display error during
Stage 2 of installation. (see screenshot) No problem when selecting English as
the language for installation.

Version-Release number of selected component (if applicable):
anaconda-10.91.4-1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.enter linux text at the prompt
2.select Chinese, Japanes or Korean as the language for installation
3.
  
Actual results:
see screenshot

Expected results:
installation proceed in english

Additional info:
Comment 1 Lawrence Lim 2006-02-07 19:50:24 EST
Created attachment 124345 [details]
screenshot of anaconda stage 2 with Traditoinal Chinese selected
Comment 2 Leon Ho 2006-02-14 01:16:19 EST
Seems this is unusable. marking this as FC5Blocker.
Comment 3 Rahul Sundaram 2006-02-20 06:04:27 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Warren Togami 2006-02-21 00:58:38 EST
Solution: If CJKI language in text install, set LANG=en_US.UTF-8?
Comment 5 David Cantrell 2006-02-21 11:17:18 EST
I think there's a problem with bogl, but I don't know enough about it to figure
it out quickly.  See the error with bogl and the /dev/fb0 error in loader2?

I modified lang-table to use en_US.UTF-8 for Chinese, Japanese, and Korean. 
Running a text mode install now has reabable text in English, which is probably
better than the screenshot above for FC5 final.

I'll close this one, but I'm opening another bug about bogl because I think
that's the real problem.
Comment 6 Bill Nottingham 2006-02-21 12:26:00 EST
Does this change what anaconda *writes*?
Comment 7 Warren Togami 2006-02-21 12:57:47 EST
To be clear, this is an issue for also Indic langauage text-mode installs.

if (CJKI && text install)
then *view* English during the text install
     write the actual language in configs
else
    Install in graphical mode viewing the native language
endif
Comment 8 David Cantrell 2006-02-21 17:56:36 EST
OK, all languages listed in lang-table as having a font of bterm or none will
now display en_US.UTF-8 during installation in text mode.  The
/etc/sysconfig/i18n file is still written with the selected language, so once
you reboot you should be seeing the correct language in firstboot and X and so
on.  Graphical installation mode is unaffected.

Changes committed to CVS, new anaconda building.  Going home.
Comment 9 Lawrence Lim 2006-03-02 18:49:34 EST
Not sure if it is a regression due to this bug. Noticed the following traceback
at the beginning of stage 2 during text installing with korean language support.

anaconda-10.92.14-1.i386.rpm

03:45:36 CRITICAL: Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1214, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line 455, in run
    "%s display is unavailable in text mode.  "
NameError: name 'oldlang' is not defined

03:45:36 INFO    : in run, screen = <snack.SnackScreen instance at 0xb7d6ca2c>
Comment 10 David Cantrell 2006-03-03 11:42:21 EST
Hmmm...possible.  Looking in to it now.
Comment 11 David Cantrell 2006-03-03 14:38:30 EST
This isn't happening to me on today's rawhide.  What language and keymap are you
selecting for text mode?
Comment 12 Lawrence Lim 2006-03-05 19:17:23 EST
RE: Comment #11
Still happen for me in today's rawhide (rawhide-20060305) anaconda-10.92.16-1.
Checked again with 'Japanese' and 'Hindi' as language, both using 'us' keymap.
Comment 13 David Cantrell 2006-03-06 09:59:12 EST
When booting rawhide, I get these messages when I select Japanese or Hindi and
the US keymap:

ja_JP.UTF-8 display is unavailable in text mode.  The installation will continue
in English.

hi_IN.UTF-8 display is unavailable in text mode.  The installation will continue
in English.

The installation proceeds in text mode, but in English.  The target system is
setup with the selected language though.

How are you getting rawhide to boot on your system?  Perhaps there are some
differences there that I'm not seeing.  I've done network and CD boots to test
this and it's working as it should.
Comment 14 Lawrence Lim 2006-03-06 18:02:00 EST
RE: Comment #13.

My bad, should have mentioned that the problem is at Stage 2 of the installation
process. Everything works correctly in Stage 1 of the installation process.
Comment 15 David Cantrell 2006-03-07 09:56:53 EST
But it's still working in stage 2.  You select Japanese or Hindi with a US
keymap and the installation proceeds all the way through in English.

Are you sure you're booting with rawhide?  This problem has been fixed.
Comment 16 A S Alam 2006-06-14 05:21:39 EDT
Envirnemt: 
------------
Rawhide Build 13June2006
--------------


Showing Following Error for ja_JP locale (us keyboard)
---------------
Traceback (most recent call last):
 File "/usr/bin/anaconda", line 959, in ?
anaconda.intf,run(anaconda)
File "/usr/bin/anaconda/text.py", line 455, in run
"%s display is unavailable in tet mode. " 
NameError: name 'oldlang' is not defined"
---------------------------

also, Button Showing SQUARE and text is broken

Comment 17 Bill Nottingham 2006-06-14 12:50:23 EDT
Please open a new bug; this is unrelated to the previous issue.
Comment 18 A S Alam 2006-08-15 03:53:03 EDT
Selected Japanese or Hindi with a US
keymap and Showing message about "<LANG> display is unavailable in text mode.
The Installation will continue in English", but it is next start in
Japanese/Hindi (as showing squares instead of characters).


Envirnemt: 
------------
Rawhide Build 14August2006
--------------
Comment 19 Chris Lumens 2006-08-17 11:28:17 EDT
This should be fixed in the next build of anaconda.
Comment 20 A S Alam 2006-08-22 03:20:38 EDT
Created attachment 134615 [details]
Message box showing that CJKI is not avaiable for stage 2

Message box showing that CJKI is not avaiable for stage 2 (Hindi installation)
Comment 21 A S Alam 2006-08-22 03:24:26 EDT
Created attachment 134616 [details]
Next page after warning
Comment 22 A S Alam 2006-08-22 03:26:58 EDT
it shows warning message, but installation continue in selected langauge 
(tested with following:
---
anaconda-11.1.0.83-1 (21August Build)
Hindi/Japanese
---

Reopening bug
Comment 23 A S Alam 2006-08-29 01:48:02 EDT
Install contine in English in stage 2. Problem fixed.
Tested with following version:
anaconda-11.1.0.84-1.i386.rpm  
Comment 24 Caius Chance 2006-09-10 23:40:53 EDT
According to the .spec file, this bug has been fixed in 10.92.6-1:

-----

It should have been fixed in current RHEL-5 branch and has been contained in the
RHEL5-Server-Beta1-RC.

-----

Please anyone have a test installation on the RHEL5-Beta1-RC.

Note You need to log in before you can comment on or make changes to this bug.