Bug 18042 - PPP and kernel 2.4.x readiness
PPP and kernel 2.4.x readiness
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 18:56 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 21:01:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-01 18:56:16 EDT
Browsing through the RPMs for RH7.0, I noticed that ppp-2.3.11 (I believe
it is) is included. However, kernel 2.4.x calls for ppp-2.4.0 since the new
ppp package supports the new features from the ppp code out of kernel
2.4.x. ppp-2.4.0 works fine with the 2.2.x kernels. The 2.4.x kernels also
require /dev/ppp, which is char-major-108, in order to work at all (I'm not
sure if the new device is more a ppp or a kernel thing.. prolly more
kernel-related but I thought I'd throw that in too) :)
Comment 1 Nalin Dahyabhai 2000-10-02 01:22:43 EDT
The pppd distribution hadn't been officially been marked "finished" for 2.4 last
time I checked, but it appears that that's changed.  We'll add pppd 2.4.0 to the
Raw Hide tree and release it when a 2.4.0 kernel is released.
Comment 2 Richard Smith 2000-11-07 12:46:05 EST
I still cant find the new PPP in Raw Hide (maybe the mirrors do not update, the
main site is always too busy).

Can someone tell me how to get PPP working with a 2.4 kernel?
Comment 3 Need Real Name 2000-11-07 14:41:14 EST
You should get ppp-2.4.0.tar.gz from someplace. Goto www.freshmeat.net and look
up ppp. "rpm -e ppp" and then compile and install from the new tarball.

The kernel help through menuconfig, etc, tells you that if you want to compile
ppp support into the kernel, you'll have to make sure that the "set version info
on all modules..." option is NOT selected (near the beginning of the config). If
you want it as a module, then it should be ok (if you have the set version info
option selected, then ppp is forced to build as a module). You'll have to create
a new device using mknod... something like "mknod -m 644 c 108 0" (note that
this device will be called char-major-108 when referenced in log files like
/var/log/messages). You should also select the modules you want with ppp (the
async module if you're using a modem, etc.. it explains it in the help) along
with any of the compression modules it offers. 

Just compile the kernel, etc.. you may need to add a couple things to
/etc/conf.modules.. this is what I added just to cover everything:

alias  char-major-108  ppp_generic
alias  /dev/ppp  ppp_generic
alias tty-ldisc-3  ppp_async
alias tty-ldisc-14  ppp_synctty
alias ppp-compress-21  off
alias ppp-compress-24  off
alias ppp-compress-26  off

the last three lines other people often set to the different compression modules
(I forget which goes with which since I don't use the compression modules).

Reboot, etc..

I'm currently using 2.2.17 since 2.4.0-test8 which I last used had a terrible
deadlock problem (processes going into D state one after another and never
coming out)... I haven't tried out test9 or test10 yet. ppp on my end with
2.4.0-test has been good in some areas.. but crap in others. Reliable sources
(he knows who he is) have informed me of what the problem might be. I just hope
it gets cleared up or else linux-2.4.x isn't going to be nice.

I hope some of what I've said has been helpful :)

Note You need to log in before you can comment on or make changes to this bug.