Bug 1804230 - Documentation Incorrect for OCP 4.4 RHV IPI Install
Summary: Documentation Incorrect for OCP 4.4 RHV IPI Install
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.8.0
Assignee: Steve Goodman
QA Contact: michal
URL:
Whiteboard:
: 1806935 (view as bug list)
Depends On:
Blocks: 1806935 1838256
TreeView+ depends on / blocked
 
Reported: 2020-02-18 14:01 UTC by Vishal Bhatia
Modified: 2021-06-29 18:58 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806935 (view as bug list)
Environment:
Last Closed: 2021-05-06 11:53:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3183 0 None closed Bug 1804230: Documentation Incorrect for OCP 4.4 RHV IPI Install 2021-02-18 17:35:28 UTC
Github openshift installer pull 4353 0 None closed Small corrections in ovirt/install_ipi.md 2021-02-18 17:35:27 UTC
Github openshift installer pull 4764 0 None open Bug 1804230: fix broken ETCD link in user docs 2021-03-17 12:11:49 UTC

Description Vishal Bhatia 2020-02-18 14:01:53 UTC
Description of problem:
Documentation is referring to a process no longer required
https://github.com/openshift/installer/blob/master/docs/user/ovirt/install_ipi.md

RHCOS OSP Image download and conversion to 

How reproducible:

Steps to Reproduce:
1. Download the latest nightly release 
    https://mirror.openshift.com/pub/openshift-v4/clients/ocp-dev-preview/4.4.0-0.nightly-2020-02-18-093529/openshift-install-linux-4.4.0-0.nightly-2020-02-18-093529.tar.gz
2. Run the installer with oVirt platform inputs


Actual results:
Installer downloads the image, uploads the disk to RHV, runs a temporary VM and converts it into a template

Expected results:
These tasks are expected to be done by the user using Ansible playbook provided
https://gist.github.com/rgolangh/adccf6d6b5eaecaebe0b0aeba9d3331b

Additional info:
Documentation needs to be updated to reflect correct steps

Comment 1 Rolfe Dlugy-Hegwer 2020-05-13 16:12:46 UTC
It seems like topics in `openshift/installer/blob/master/docs/user` such as `/ovirt/install_ipi.md` duplicate documentation in `https://github.com/openshift/openshift-docs`. Occasional users get lost and confused by this.

I recommend replacing the content of /install_ipi.md and with a suggestion: "For details on installing OpenShift on oVirt/RHV, to go to https://docs.openshift.com/container-platform/4.4/installing/installing_rhv/installing-rhv-default.html"

Comment 2 Rolfe Dlugy-Hegwer 2020-05-13 16:43:36 UTC
Otherwise, consider setting Status to CLOSED > UPSTREAM.

Comment 5 Douglas Schilling Landgraf 2020-05-27 10:20:04 UTC
*** Bug 1806935 has been marked as a duplicate of this bug. ***

Comment 7 Jan Zmeskal 2020-06-01 12:49:33 UTC
Hi Roy, when verifying this, I did not really focus on the language point of view since this is upstream doc. However, there are few functional things I think should be fixed before moving to VERIFIED.

1. Link to OpenShift-Metal³ kni-installer points to an old, seemingly deprecated repository.

2. To work with this provider one must supply 2 IPs that are related to any MAC in the virtualization env -> ...2 IPs that are *not* related to any MAC...

3. We tell user to put $DNS_VIP into their /etc/resolv.conf. We can definitely keep it there as a workaround, but I believe that primarily we should tell them to create DNS entries for API_VIP and INGRESS_VIP

4. In minimum requirements, we still say that they should have storage that can do 50 IOPS. However, our testing showed that this is not so easy. I recommend linking this article: https://www.ibm.com/cloud/blog/using-fio-to-tell-whether-your-storage-is-fast-enough-for-etcd

Comment 8 Sandro Bonazzola 2020-06-18 06:54:40 UTC
due to capacity constraints we will be revisiting this bug in the upcoming sprint

Comment 10 Douglas Schilling Landgraf 2020-07-09 12:14:16 UTC
due to capacity constraints we will be revisiting this bug in the upcoming sprint

Comment 11 Douglas Schilling Landgraf 2020-07-20 11:20:40 UTC
Hi Jan,

(In reply to Jan Zmeskal from comment #7)
> Hi Roy, when verifying this, I did not really focus on the language point of
> view since this is upstream doc. However, there are few functional things I
> think should be fixed before moving to VERIFIED.
> 
> 1. Link to OpenShift-Metal³ kni-installer points to an old, seemingly
> deprecated repository.
> 
> 2. To work with this provider one must supply 2 IPs that are related to any
> MAC in the virtualization env -> ...2 IPs that are *not* related to any
> MAC...
> 
> 3. We tell user to put $DNS_VIP into their /etc/resolv.conf. We can
> definitely keep it there as a workaround, but I believe that primarily we
> should tell them to create DNS entries for API_VIP and INGRESS_VIP
> 
> 4. In minimum requirements, we still say that they should have storage that
> can do 50 IOPS. However, our testing showed that this is not so easy. I
> recommend linking this article:
> https://www.ibm.com/cloud/blog/using-fio-to-tell-whether-your-storage-is-
> fast-enough-for-etcd


Looks like all your comments are included in the current documentation.
Could you please double check?

Comment 12 Jan Zmeskal 2020-07-20 11:25:20 UTC
Hi Douglas, just to make sure we are both on the same page - I understand this bug as referring to upstream documentation that lives in the GH repo. If you believe all of my suggestions have been implemented, feel free to move this to ON_QA and I'll be sure to check it out.

Comment 13 Sandro Bonazzola 2020-09-14 09:33:12 UTC
(In reply to Jan Zmeskal from comment #12)
> Hi Douglas, just to make sure we are both on the same page - I understand
> this bug as referring to upstream documentation that lives in the GH repo.
> If you believe all of my suggestions have been implemented, feel free to
> move this to ON_QA and I'll be sure to check it out.

Douglas not around till November, let's get this moving on in next sprint.

Comment 14 Jan Zmeskal 2020-09-22 11:21:01 UTC
I took a look at https://github.com/openshift/installer/blob/master/docs/user/ovirt/install_ipi.md (notice the master branch in the path) and all of my original objections from comment 7 (with the exception of #3) still persist. Either we must show commitment to maintaining the upstream docs and fix those issues or do what Rolfe suggests in comment 1. I don't mind either way, but one of those things needs to happen before this can be verified.

Comment 15 Roy Golan 2020-11-08 10:23:21 UTC
(In reply to Jan Zmeskal from comment #7)

I addressed 1-3 [1] and left 4 open meanwhile because I prefer the official etcd docs after all, at
least in the developer documentation. 

[1] https://github.com/openshift/installer/pull/4353

I assume this bug can be closed as it should cover the official docs and not the installer repo docs?

Comment 16 Steve Goodman 2021-03-08 11:15:05 UTC
It appears from comment 15 that Roy addressed Jan's concerns in comment 7, so moving to ON_QA.

If something still needs to be done, please state clearly what that is. As far as I can see, the concern in comment 0 has been addressed.

Comment 17 michal 2021-03-17 11:29:25 UTC
as I understand I verified this :
1. Link to OpenShift-Metal³ kni-installer points to an old, seemingly
> deprecated repository.

-> the name of link change to 'Bare Metal IPI Networking Infrastructure' and work fine
> 
> 2. To work with this provider one must supply 2 IPs that are related to any
> MAC in the virtualization env -> ...2 IPs that are *not* related to any
> MAC...

-> change to 'excluded from the MAC range'
> 
> 3. We tell user to put $DNS_VIP into their /etc/resolv.conf. We can
> definitely keep it there as a workaround, but I believe that primarily we
> should tell them to create DNS entries for API_VIP and INGRESS_VIP

-> there is no mention to resolv.conf, only to API_VIP
Name resolution of api_vip from your installing machine The installer must resolve the api_vip during the installation, as it will interact with the API to follow the cluster version progress.

4. In minimum requirements, we still say that they should have storage that
> can do 50 IOPS. However, our testing showed that this is not so easy. I
> recommend linking this article:
> https://www.ibm.com/cloud/blog/using-fio-to-tell-whether-your-storage-is-
> fast-enough-for-etcd

-<the link to 50IOPS for the Master VM disks, per ETCD requirement doc is broken

Comment 18 michal 2021-03-17 16:26:58 UTC
check the link in the latest version and it is working
https://github.com/openshift/installer/blob/master/docs/user/ovirt/install_ipi.md

Comment 19 Steve Goodman 2021-05-06 11:53:41 UTC
This has been verified and it appears there's nothing left to do on it. So I'm closing this bug.

If you feel that this is incorrect, please reopen with a comment describing what is still necessary to do to address this.


Note You need to log in before you can comment on or make changes to this bug.