Bug 1804254 - templates are prefilled incorrectly in flavor modal
Summary: templates are prefilled incorrectly in flavor modal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1807600
TreeView+ depends on / blocked
 
Reported: 2020-02-18 14:30 UTC by Filip Krepinsky
Modified: 2020-07-13 17:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: wrong templates were chosen in VM flavor modal Consequence: wrong CPU/Memory values and labels were set to the VM Fix and Result: It is not possible to expect that templates will be compatible. So currently it is possible to switch only between the underlying template and CUSTOM mem/cpu and the underlying template is never changed.
Clone Of:
: 1807600 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:15:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4510 0 None closed Bug 1804254: deprecate unreliable template switching in flavor modal 2020-07-02 19:16:22 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:16:10 UTC

Description Filip Krepinsky 2020-02-18 14:30:59 UTC
Description of problem:
Wrong values are loaded from base template.

How reproducible:
100


Steps to Reproduce:
1. Create a fedora template with Custom flavor (1 cpu,1 GiB RAM) with the Wizard
2. change the flavor in flavor modal to small/large etc.
3. the cpu and memory is copied from wrong templates (e.g. windows and centos)
4. The template is labeled and annotated inccorectly (base template pointers, vmi labels)


Actual results:


Expected results:
All correct values are preffiled and changed accordingly 


Additional info:
User templates are not taken into account when changing the flavor of VM - e.g. validations

Comment 1 Filip Krepinsky 2020-02-26 14:10:21 UTC
The definition of the bug has changed as the requirements changed. There should not be any changing of the underlying template in flavor modal, so we should revert this feature and allow only:

- flavor from the user/one base template
- custom flavor

Comment 4 Guohua Ouyang 2020-03-31 07:39:25 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016.

Comment 6 errata-xmlrpc 2020-07-13 17:15:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.