Bug 1804284 - using `ip=dhcp,dhcp6` on kernel cmdline prevents mutli-NIC nodes from fully initializing
Summary: using `ip=dhcp,dhcp6` on kernel cmdline prevents mutli-NIC nodes from fully i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Micah Abbott
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-18 15:42 UTC by Micah Abbott
Modified: 2020-05-13 21:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:59:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3117 0 None closed Bug 1804284: Revert "RHCOS: bump to 44.81.202002071430-0" 2020-05-04 15:38:04 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:59:09 UTC

Description Micah Abbott 2020-02-18 15:42:01 UTC
The root cause of the problem needs to be investigated in BZ#1803926

This BZ is needed to revert the RHCOS boot image bump that introduced the `ip=dhcp,dhcp6` change.

Comment 3 Michael Nguyen 2020-02-25 17:59:55 UTC
Verified boot image for 4.4.0-0.nightly-2020-02-20-232701 is RHCOS 44.81.202001241431.0 which contains ip=dhcp

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-02-20-232701   True        False         12m     Cluster version is 4.4.0-0.nightly-2020-02-20-232701
$ oc get nodes
NAME                           STATUS   ROLES    AGE   VERSION
ip-10-0-137-234.ec2.internal   Ready    worker   22m   v1.17.1
ip-10-0-138-244.ec2.internal   Ready    master   32m   v1.17.1
ip-10-0-147-51.ec2.internal    Ready    master   32m   v1.17.1
ip-10-0-149-196.ec2.internal   Ready    worker   23m   v1.17.1
ip-10-0-161-81.ec2.internal    Ready    master   32m   v1.17.1
ip-10-0-168-58.ec2.internal    Ready    worker   23m   v1.17.1
$ oc debug node/ip-10-0-138-244.ec2.internal
Starting pod/ip-10-0-138-244ec2internal-debug ...
To use host binaries, run `chroot /host`
If you don't see a command prompt, try pressing enter.
sh-4.2# chroot /host
sh-4.4# rpm-ostree status
State: idle
AutomaticUpdates: disabled
Deployments:
* pivot://quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:4929fe7bf9da2772d975f600e7a5405d875732316df06b70331ac7338476f708
              CustomOrigin: Managed by machine-config-operator
                   Version: 44.81.202002202031-0 (2020-02-20T20:36:45Z)

  ostree://f61524fda480c611dcd25629fd15eb6de27a306689261c211dbc8e88c19a5219
                   Version: 44.81.202001241431.0 (2020-01-24T14:36:48Z)

Comment 5 errata-xmlrpc 2020-05-13 21:59:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.