Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1804408 - [IPI Baremetal] CAPBM is vendoring old BareMetalHost code
Summary: [IPI Baremetal] CAPBM is vendoring old BareMetalHost code
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Steven Hardy
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-18 18:24 UTC by Doug Hellmann
Modified: 2020-05-13 21:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:59:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-baremetal pull 49 0 None closed Bug 1804408: update vendored copy of baremetal-operator 2020-05-19 17:00:49 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:59:11 UTC

Description Doug Hellmann 2020-02-18 18:24:31 UTC
Description of problem:

The openshift/cluster-api-provider-baremetal has an outdated copy of the BareMetalHost definition, which causes data loss when the actuator updates a host as part of provisioning.


Version-Release number of selected component (if applicable):

4.4


How reproducible:

Every time.

Steps to Reproduce:
1. Set the flag to disable certificate validation in BMC communication.
2. Provision the host.


Actual results:

The flag is cleared so that cert validation is re-enabled.

Expected results:

The flag stays set to disable cert validation.

Additional info:

Comment 3 errata-xmlrpc 2020-05-13 21:59:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.