Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1804562 - An instance get a duplicated attachments about the same volume
Summary: An instance get a duplicated attachments about the same volume
Keywords:
Status: CLOSED DUPLICATE of bug 1705563
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Cinder Bugs List
QA Contact: Tzach Shefi
Chuck Copello
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 07:40 UTC by Takashi Kajinami
Modified: 2020-02-19 09:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-19 09:59:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Takashi Kajinami 2020-02-19 07:40:01 UTC
Description of problem:

We sometimes observe that an instance has duplicated attachments for the same volume,
while the volume has also duplicated attachments for the instance.

This causes wrong handling of block devices in nova, and causes issue in the instance,
or the failure when rebooting the instance caused by duplicated lock about the same volume

How reproducible:
It doesn't always happen, but sometime does.
We observe that it tends to happen when ocp on top of osp continuously reties to attach a volume to an instance

Steps to Reproduce:
1. Create volume A
2. Create instance B
3. Attach a volume A to instance B concurrently

Actual results:
The instance B sometimes gets duplicated attachments for the volume A


Expected results:
The instance B never gets duplicated attachments for the volume A


Additional info:

Comment 2 Luigi Toscano 2020-02-19 09:18:10 UTC
This bug looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1705563. Can you please check the deployed version of cinder?

Comment 5 Luigi Toscano 2020-02-19 09:59:51 UTC
As it seems that an older version is used (openstack-cinder-12.0.3-2.el7ost.noarch), closing as duplicate for now. The bug can be reopened if the issue is still visible after an update.

*** This bug has been marked as a duplicate of bug 1705563 ***


Note You need to log in before you can comment on or make changes to this bug.