Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1804711

Summary: satellite-maintain snapshot backup do not restore the Red Hat Satellite services if it fails.
Product: Red Hat Satellite Reporter: Akshay Kapse <akapse>
Component: Satellite MaintainAssignee: Suraj Patil <supatil>
Status: CLOSED DUPLICATE QA Contact: Lucie Vrtelova <lvrtelov>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 6.6.0CC: ahumbe, apatel, its.system.support.unix, kgaikwad, surpatil, vdeshpan, yoliynyk
Target Milestone: UnspecifiedKeywords: PrioBumpQA, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-21 12:15:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Akshay Kapse 2020-02-19 13:51:30 UTC
Description of problem:
satellite-maintain snapshot backup fails to restore the services if it fails at any stage of backup.

Version-Release number of selected component (if applicable):
6.6

How reproducible:
Always

Steps to Reproduce:
1) Check the services status.
2) Rhun below command to take the backup:
# satellite-maintain backup snapshot --assumeyes /var/log/foremain_maintain_$(date +%F_%H_%M).log

If the backup fails which can happen due to multiple reasons, then restore services part won't get executed. This results in Red Hat Satellite server in unresponsive state.

To restore the server back, need to restart the services manually like:
# katello-service restart


Actual results:
Failed Red Hat Satellite server services.

Expected results:
Should restore the Red Hat Satellite services back even if the backup fails at any stage.

Comment 4 Suraj Patil 2020-05-14 11:55:29 UTC
Created redmine issue https://projects.theforeman.org/issues/29816 from this bug

Comment 5 Bryan Kearney 2020-05-14 12:02:24 UTC
Upstream bug assigned to supatil

Comment 6 Vedashree Deshpande 2021-02-04 10:06:28 UTC
Is there any update? The customer is waiting for this fix for a long time now.

Comment 9 Ashish Humbe 2021-04-21 12:15:35 UTC

*** This bug has been marked as a duplicate of bug 1908478 ***

Comment 10 Red Hat Bugzilla 2023-09-15 00:29:41 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 500 days