Bug 1804716 - panic: runtime.boundsError
Summary: panic: runtime.boundsError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1807018
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 14:01 UTC by Phil Cameron
Modified: 2020-05-04 11:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1807018 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:37:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 204 0 None closed Bug 1804716: etcdcli: fix out-of-bounds panic 2020-11-18 22:38:21 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:38:06 UTC

Description Phil Cameron 2020-02-19 14:01:57 UTC
Description of problem:ci test log shows panic

https://gcsweb-ci.svc.ci.openshift.org/gcs/origin-ci-test/pr-logs/pull/openshift_cluster-network-operator/456/pull-ci-openshift-cluster-network-operator-master-e2e-gcp/768/artifacts/

./e2e-gcp/pods/openshift-etcd-operator_etcd-operator-d8649847d-rlpg2_operator.log

I0218 13:27:35.451821       1 balancer_conn_wrappers.go:127] pickfirstBalancer: HandleSubConnStateChange: 0xc000511f10, READY
E0218 13:27:35.459444       1 runtime.go:78] Observed a panic: runtime.boundsError{x:0, y:0, signed:true, code:0x0} (runtime error: index out of range [0] with length 0)
goroutine 872 [running]:
k8s.io/apimachinery/pkg/util/runtime.logPanic(0x1f36440, 0xc00190c360)
        k8s.io/apimachinery@v0.17.1/pkg/util/runtime/runtime.go:74 +0xa3
k8s.io/apimachinery/pkg/util/runtime.HandleCrash(0x0, 0x0, 0x0)
        k8s.io/apimachinery@v0.17.1/pkg/util/runtime/runtime.go:48 +0x82
panic(0x1f36440, 0xc00190c360)
        runtime/panic.go:679 +0x1b2
github.com/openshift/cluster-etcd-operator/pkg/etcdcli.(*etcdClientGetter).UnhealthyMembers(0xc000a26de0, 0x0, 0x0, 0x0, 0x0, 0x0)
        github.com/openshift/cluster-etcd-operator@/pkg/etcdcli/etcdcli.go:211 +0x4e7
github.com/openshift/cluster-etcd-operator/pkg/operator/bootstrapteardown.(*BootstrapTeardownController).hasMoreThanTwoEtcdMembers(0xc000767680, 0xc0005fcec0, 0xc000ff5c18, 0x1)
        github.com/openshift/cluster-etcd-operator@/pkg/operator/bootstrapteardown/bootstrap_teardown_controller.go:193 +0x71
github.com/openshift/cluster-etcd-operator/pkg/operator/bootstrapteardown.(*BootstrapTeardownController).removeBootstrap(0xc000767680, 0xc00050def0, 0xc000a183c0)
        github.com/openshift/cluster-etcd-operator@/pkg/operator/bootstrapteardown/bootstrap_teardown_controller.go:140 +0x1f7
github.com/openshift/cluster-etcd-operator/pkg/operator/bootstrapteardown.(*BootstrapTeardownController).sync(0xc000767680, 0x1d09440, 0x2408580)
        github.com/openshift/cluster-etcd-operator@/pkg/operator/bootstrapteardown/bootstrap_teardown_controller.go:86 +0x40
github.com/openshift/cluster-etcd-operator/pkg/operator/bootstrapteardown.(*BootstrapTeardownController).processNextWorkItem(0xc000767680, 0x0)
        github.com/openshift/cluster-etcd-operator@/pkg/operator/bootstrapteardown/bootstrap_teardown_controller.go:297 +0xcf
github.com/openshift/cluster-etcd-operator/pkg/operator/bootstrapteardown.(*BootstrapTeardownController).runWorker(0xc000767680)
        github.com/openshift/cluster-etcd-operator@/pkg/operator/bootstrapteardown/bootstrap_teardown_controller.go:286 +0x2b
k8s.io/apimachinery/pkg/util/wait.JitterUntil.func1(0xc0017be950)
        k8s.io/apimachinery@v0.17.1/pkg/util/wait/wait.go:152 +0x5e
k8s.io/apimachinery/pkg/util/wait.JitterUntil(0xc0017be950, 0x3b9aca00, 0x0, 0x1, 0xc0001253e0)
        k8s.io/apimachinery@v0.17.1/pkg/util/wait/wait.go:153 +0xf8
k8s.io/apimachinery/pkg/util/wait.Until(0xc0017be950, 0x3b9aca00, 0xc0001253e0)
        k8s.io/apimachinery@v0.17.1/pkg/util/wait/wait.go:88 +0x4d
created by github.com/openshift/cluster-etcd-operator/pkg/operator/bootstrapteardown.(*BootstrapTeardownController).Run
        github.com/openshift/cluster-etcd-operator@/pkg/operator/bootstrapteardown/bootstrap_teardown_controller.go:274 +0x219


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 ge liu 2020-03-02 11:15:45 UTC
Checked latest build log this issue still exist(https://storage.googleapis.com/origin-ci-test/pr-logs/pull/openshift_cluster-network-operator/456/pull-ci-openshift-cluster-network-operator-master-e2e-gcp/792/artifacts/e2e-gcp/pods/openshift-etcd-operator_etcd-operator-67999b8f7b-zvswh_operator.log),
but think about the fix have been merged at Feb 25, and latest build log is Feb 21, so the code should have been merged now, and close it because the clone bug add no-qe tag.

Comment 7 errata-xmlrpc 2020-05-04 11:37:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.