Bug 1804717 - improve reliability during upgrade by using a deployment
Summary: improve reliability during upgrade by using a deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Maru Newby
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1805872
TreeView+ depends on / blocked
 
Reported: 2020-02-19 14:02 UTC by David Eads
Modified: 2020-07-13 17:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1805388 1805872 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:16:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-openshift-apiserver-operator pull 313 None closed bug 1804717: Switch to managing openshift-apiserver pods with a deployment 2020-07-20 12:15:09 UTC
Github openshift cluster-openshift-apiserver-operator pull 324 None closed bug 1804717: Cleanup switch to managing openshift-apiserver pods with a deployment 2020-07-20 12:15:08 UTC
Red Hat Knowledge Base (Solution) 4726211 None None None 2020-05-11 15:05:40 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:16:36 UTC

Description David Eads 2020-02-19 14:02:06 UTC
DaemonSets are special cased during host shutdown and don't get a chance to gracefully fail over.  This can cause problems with both connectivity on a kill (non-grace shutdown) and sudden loss of etcd connection.

Switching to a deployment will alleviate symptoms.  We original chose a daemonset for spreading and for scaling.  For spreading, we now have anti-affinity rules.  For scaling, we should wire into something like an HPA anyway.

The migration will require PRs back to 4.3 which remove the deployment on downgrade and in 4.4 to remove the daemonset.

Comment 1 Maru Newby 2020-02-27 07:16:05 UTC
Resetting status to allow follow-on PR to use the same bz.

Comment 5 Ryan Phillips 2020-05-11 15:05:40 UTC
*** Bug 1790989 has been marked as a duplicate of this bug. ***

Comment 8 Ryan Phillips 2020-05-14 18:41:49 UTC
*** Bug 1790989 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2020-07-13 17:16:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.