Bug 1804748 - Openshift installation fails - missing Kuryr admission-controller due to incorrect multiple-listeners octavia support detection
Summary: Openshift installation fails - missing Kuryr admission-controller due to inco...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Michał Dulko
QA Contact: GenadiC
URL:
Whiteboard:
Depends On: 1804734
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 14:48 UTC by Michał Dulko
Modified: 2020-05-04 11:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1804734
Environment:
Last Closed: 2020-05-04 11:37:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 488 0 None closed [release-4.4] Bug 1804748: Kuryr: Disable multiple listeners for OVN provider 2020-09-14 10:52:56 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:38:06 UTC

Description Michał Dulko 2020-02-19 14:48:59 UTC
+++ This bug was initially created as a clone of Bug #1804734 +++

Description of problem:
Openshift installation fails 

[stack@undercloud-0 ~]$ oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version             False       True          63m     Unable to apply 4.4.0-0.nightly-2020-02-18-211831: an unknown error has occurred
[stack@undercloud-0 ~]$ oc get co
NAME                                       VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                                                                 Unknown     Unknown       True       50m
cloud-credential                           4.4.0-0.nightly-2020-02-18-211831   True        False         False      63m
csi-snapshot-controller                    4.4.0-0.nightly-2020-02-18-211831   False       True          False      31m
dns                                        4.4.0-0.nightly-2020-02-18-211831   True        False         False      43m
etcd                                       4.4.0-0.nightly-2020-02-18-211831   True        False         False      41m
insights                                   4.4.0-0.nightly-2020-02-18-211831   True        False         False      50m
kube-apiserver                             4.4.0-0.nightly-2020-02-18-211831   True        False         False      46m
kube-controller-manager                    4.4.0-0.nightly-2020-02-18-211831   True        False         False      44m
kube-scheduler                             4.4.0-0.nightly-2020-02-18-211831   True        False         False      47m
kube-storage-version-migrator              4.4.0-0.nightly-2020-02-18-211831   True        False         False      32m
machine-api                                4.4.0-0.nightly-2020-02-18-211831   True        False         False      47m
machine-config                             4.4.0-0.nightly-2020-02-18-211831   True        False         False      44m
network                                    4.4.0-0.nightly-2020-02-18-211831   True        False         False      50m
node-tuning                                4.4.0-0.nightly-2020-02-18-211831   True        False         False      50m
openshift-apiserver                        4.4.0-0.nightly-2020-02-18-211831   False       False         True       50m
openshift-controller-manager               4.4.0-0.nightly-2020-02-18-211831   True        False         False      48m
operator-lifecycle-manager                 4.4.0-0.nightly-2020-02-18-211831   True        False         False      47m
operator-lifecycle-manager-catalog         4.4.0-0.nightly-2020-02-18-211831   True        False         False      47m
operator-lifecycle-manager-packageserver   4.4.0-0.nightly-2020-02-18-211831   True        False         False      45m
service-ca                                 4.4.0-0.nightly-2020-02-18-211831   True        False         False      50m
service-catalog-apiserver                  4.4.0-0.nightly-2020-02-18-211831   True        False         False      50m
service-catalog-controller-manager         4.4.0-0.nightly-2020-02-18-211831   True        False         False      50m

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-18-211831
OSP16 RHOS_TRUNK-16.0-RHEL-8-20200213.n.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Itzik Brown 2020-02-25 11:50:47 UTC
Checked with 4.4.0-0.nightly-2020-02-24-105333

Comment 5 errata-xmlrpc 2020-05-04 11:37:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.