Bug 180481 - (PR_GetAddrInfoByName) Use PR_GetAddrInfoByName instead of PR_GetIPNodeByName/PR_GetHostByAddr
Use PR_GetAddrInfoByName instead of PR_GetIPNodeByName/PR_GetHostByAddr
Status: CLOSED DUPLICATE of bug 206724
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 10:18 EST by Rich Megginson
Modified: 2007-04-18 13:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 18:50:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2006-02-08 10:18:53 EST
PR_GetAddrInfoByName is the preferred method to get address information for an
IP address (IPv4 and IPv6) and to enumerate hostname lookups.  We especially
need this for HP-UX to support IPv6, because the older functions are based on
the deprecated getipnodebyname function, which is broken in HP-UX B.11.11 (with
IPv6 patch applied).  Instead of fixing PR_GetIPNodeByName for HP-UX B.11.11, we
should switch to the new PR_GetAddrInfoByName function.
Comment 1 Wan-Teh Chang 2006-02-08 16:09:59 EST
We should replace all gethostbyname, PR_GetHostByName,
and PR_GetIPNodeByName calls with PR_GetAddrInfoByName
calls.  PR_GetAddrInfoByName supports both IPv4 and
IPv6, so we can test the new code on IPv4 networks now.
(In fact, PR_GetAddrInfoByName is supposed to make the
code more oblivious of the protocol address family.)
This work doesn't need to wait until we have set up an
IPv6 network.
Comment 2 Rich Megginson 2006-10-09 18:35:08 EDT
Was this already done as part of IPv6 enabling the server?  If so, can someone
mark this as a duplicate?
Comment 3 Noriko Hosoi 2006-10-09 18:50:03 EDT
Sorry, the subject of 206724 "Replacing PR_SetNetAddr with PRLDAP_SET_PORT for
IPv6 support" does not mention PR_GetAddrInfoByName, but the fix includes the
replacement, as well.

*** This bug has been marked as a duplicate of 206724 ***

Note You need to log in before you can comment on or make changes to this bug.