Bug 1804929 - Create operand workflow does not sync array field groups between YAML and Form editors
Summary: Create operand workflow does not sync array field groups between YAML and For...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1796539
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 22:06 UTC by bpeterse
Modified: 2020-05-04 11:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1796539
Environment:
Last Closed: 2020-05-04 11:38:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4654 0 None closed [release-4.4] Bug 1804929: Fix Create Operand form arrayFieldGroup visuals and data syncing 2020-04-21 14:39:15 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:38:30 UTC

Description bpeterse 2020-02-19 22:06:18 UTC
+++ This bug was initially created as a clone of Bug #1796539 +++

Description of problem:

Create operand workflow does not sync array field groups between YAML and Form editors

Version-Release number of selected component (if applicable):
4.4.0


How reproducible:
Always


Steps to Reproduce:
1. Create a new project if you don't have one
2. Navigate to Operators > OperatorHub
3. Make sure the project from step 1 is the currently active namespace
3. Filter by keyword "Prometheus"
4. Click the Prometheus Operator tile
5. Click 'Install' in the resulting modal
6. Make sure the following options are selected:
    - Installation Mode: A specific namespace on the cluster
      (make sure the project from step 1 is selected)
    - Update Channel: beta
    - Approval Strategy: Automatic
7. Click "Subscribe"
8. Navigate to Operators > Installed Operators
9. Click the "Prometheus Operator" link in the installed operators list
10. In the Provided APIs section, click "Create Instance" in the first card "Prometheus"
11. Click "Edit Form" in the top right
12. Enter "test" into Image Pull Secrets > Name field
13. Click "Add Field Group" under Image Pull Secrets section
14. Enter "test1" into the new Image Pull Secrets > Name field
15. Click "Edit YAML" in the top right
16. Look for the "Image Pull Secrets" field in the YAML editor and make sure it matches the values entered in the form
17. Change the value of the second image pull secret to "test1234"
18. Click "Edit Form"

 

Actual results:
Only the first image pull secret is displayed on the form editor

Expected results:
Both image pull secrets should be displayed


Additional info:

--- Additional comment from Jon Jackson on 2020-01-30 17:16:04 UTC ---

Comment 3 shahan 2020-03-06 04:20:01 UTC
Perform the verification steps according to description comment #0, then check two new added pull secrets with name test & test1234  on the form page.
4.4.0-0.nightly-2020-03-06-030852

Comment 5 errata-xmlrpc 2020-05-04 11:38:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.