Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1804937 - [4.4.0] ocm-o reports "Progressing=False" while upgrade is in progress
Summary: [4.4.0] ocm-o reports "Progressing=False" while upgrade is in progress
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard: devex
Depends On: 1804434
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 22:19 UTC by Adam Kaplan
Modified: 2020-05-04 11:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the operator for openshift-controller-manager reported that it was not progressing, even though a rollout of the controller manager was in progress Consequence: the operator prematurely reports that the controller manager is upgraded and available Fix: report that the operator is progressing until the daemonset for the openshift-controller-manager reports that all updated pods have been scheduled Result: the openshift-controller-manager operator does not prematurely report that its update has completed
Clone Of: 1804434
Environment:
Last Closed: 2020-05-04 11:38:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-openshift-controller-manager-operator pull 142 0 None closed Bug 1804937: Report "Progressing=True" during ds rollout 2020-04-17 17:48:56 UTC
Github openshift origin pull 24587 0 None closed [release-4.4] Bug 1804937: builds: Only check ocm progress state 2020-04-17 17:48:56 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:38:30 UTC

Description Adam Kaplan 2020-02-19 22:19:41 UTC
+++ This bug was initially created as a clone of Bug #1804434 +++

Description of problem:

During upgrade, ocm-o reports `Progressing=False` even though the daemonset for the controller is still upgrading and the latest version is not being reported.


Version-Release number of selected component (if applicable): 4.4.0


How reproducible: Sometimes


Expected results:

The operator should report `Progressing=True` until the daemonset rollout has completed.


Additional info:

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_machine-config-operator/1484/pull-ci-openshift-machine-config-operator-master-e2e-gcp-upgrade/1098

Comment 4 wewang 2020-02-27 09:33:57 UTC
Verified in version:
4.4.0-0.nightly-2020-02-26-185356

STEPS:
1. Update build.config.openshift.io, check when 3 pods are not all running in openshift-controller-manager project, then ocm-o report "Progressing=True"
[wewang@wangwen ~]$ oc get co -w |grep "openshift-controller-manager"

openshift-controller-manager               4.4.0-0.nightly-2020-02-26-185356   True        True          False      9h
openshift-controller-manager               4.4.0-0.nightly-2020-02-26-185356   True        True          False      9h
openshift-controller-manager               4.4.0-0.nightly-2020-02-26-185356   True        True          False      9h
openshift-controller-manager               4.4.0-0.nightly-2020-02-26-185356   True        True          False      9h
openshift-controller-manager               4.4.0-0.nightly-2020-02-26-185356   True        False         False      9h  # 3 pods are running

Comment 7 errata-xmlrpc 2020-05-04 11:38:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.