Bug 1804978 - plymouth crashes when writing out runtime data
Summary: plymouth crashes when writing out runtime data
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1801476 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 02:00 UTC by Chris Murphy
Modified: 2020-03-12 18:57 UTC (History)
4 users (show)

Fixed In Version: plymouth-0.9.4-13.20200306git58a7289.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-12 18:57:10 UTC
Type: Bug


Attachments (Terms of Use)
journal (624.21 KB, text/plain)
2020-02-20 02:01 UTC, Chris Murphy
no flags Details
gdb stack trace plymouth (7.32 KB, text/plain)
2020-02-20 02:02 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2020-02-20 02:00:30 UTC
Description of problem:

Soon after
[   68.177974] vm.local systemd[1]: Starting Tell Plymouth To Write Out Runtime Data...

AVC and crash

[   68.185876] vm.local systemd[1]: Received SIGRTMIN+20 from PID 1350 (plymouthd).
[   68.189006] vm.local audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=plymouth-read-write comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   68.189222] vm.local audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=plymouth-read-write comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'


Version-Release number of selected component (if applicable):

plymouth-0.9.4-12.20191022git32c097c.fc32.x86_64
selinux-policy-3.14.5-26.fc32.noarch


How reproducible:
Always, unless enforcing=0


Steps to Reproduce:
1. Boot
2.
3.

Actual results:

Crash


Expected results:


No crash

Additional info:

Comment 1 Chris Murphy 2020-02-20 02:01:31 UTC
Created attachment 1664219 [details]
journal

Comment 2 Chris Murphy 2020-02-20 02:02:13 UTC
Created attachment 1664220 [details]
gdb stack trace plymouth

Comment 3 Hans de Goede 2020-03-09 09:54:22 UTC
Looking at the journal logs this seems to be caused by the systemd issue where systemd is restarting plymouth when it shouldn't (bug 1803293).

That systemd issue has been fixed and with the latest Fedora 32 + a plymouth update which I've just prepared to fix bug 1810070 I cannot reproduce this.

That plymouth update does bring in one commit from upstream which might help (it is not entirely clear to me what selinux was exactly blocking), so I will make that update close this bug in the case the reason I cannot reproduce this is because of the upstream changes.

Comment 4 Hans de Goede 2020-03-09 10:36:35 UTC
*** Bug 1801476 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2020-03-09 10:49:47 UTC
FEDORA-2020-effccc3c17 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-effccc3c17

Comment 6 Fedora Update System 2020-03-09 14:54:53 UTC
plymouth-0.9.4-13.20200306git58a7289.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-effccc3c17

Comment 7 Fedora Update System 2020-03-12 18:57:10 UTC
plymouth-0.9.4-13.20200306git58a7289.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.