Bug 1805033 - Nightly upgrade tuned pods couldn't be started
Summary: Nightly upgrade tuned pods couldn't be started
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jiří Mencák
QA Contact: Simon
URL:
Whiteboard:
Depends On:
Blocks: 1795665
TreeView+ depends on / blocked
 
Reported: 2020-02-20 06:34 UTC by Jiří Mencák
Modified: 2020-05-13 21:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:59:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:59:33 UTC

Description Jiří Mencák 2020-02-20 06:34:50 UTC
Description of problem:
A race condition exists in upgrades for node tuning operator.


How reproducible:
Rare

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install a 4.4 cluster with an older nightly release.
2. Perform an upgrade to the latest 4.4 nightly release.

Actual results:


Expected results:


Additional info:

Comment 1 Simon 2020-02-20 13:44:11 UTC
Retest positive.

cluster version: 4.4.0-0.nightly-2020-02-18-200822

Comment 4 errata-xmlrpc 2020-05-13 21:59:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.