Bug 180509 - spec file is missing %files section
spec file is missing %files section
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libnet (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 13:40 EST by Joost Soeterbroek
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 12:19:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joost Soeterbroek 2006-02-08 13:40:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
The spec file is building libnet-devel, but not libnet package.
This is due to missing %files section (%files devel is present). 

Is this missing for a particular reason or accident?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. check out libnet module from FE CVS
2. build (make i386)
3. observe libnet package is not build


Actual Results:  [....]
Wrote: /home/joost/cvs/fedora/libnet/FC-4/libnet-1.1.2.1-6.src.rpm
Wrote: /home/joost/cvs/fedora/libnet/FC-4/i386/libnet-devel-1.1.2.1-6.i386.rpm
Wrote: /home/joost/cvs/fedora/libnet/FC-4/i386/libnet-debuginfo-1.1.2.1-6.i386.rpm
[....]

Expected Results:  [....]
Wrote: /home/joost/cvs/fedora/libnet/FC-4/libnet-1.1.2.1-6.src.rpm
Wrote: /home/joost/cvs/fedora/libnet/FC-4/i386/libnet-1.1.2.1-6.i386.rpm
Wrote: /home/joost/cvs/fedora/libnet/FC-4/i386/libnet-devel-1.1.2.1-6.i386.rpm
Wrote: /home/joost/cvs/fedora/libnet/FC-4/i386/libnet-debuginfo-1.1.2.1-6.i386.rpm
[....]

Additional info:
Comment 1 Patrice Dumas 2006-02-08 13:49:42 EST
it is intentionnal, and because the libnet package itself is empty, because
there are only static libraries. If you want there is a thread on the extras
mailing list I initiated regarding that subject.

Note You need to log in before you can comment on or make changes to this bug.