Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1805184 - Cannot set bond options to `updelay=0` with `miimon=0`
Summary: Cannot set bond options to `updelay=0` with `miimon=0`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 8.2
Assignee: Antonio Cardace
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: nmstate-nm 1805205
TreeView+ depends on / blocked
 
Reported: 2020-02-20 13:10 UTC by Gris Ge
Modified: 2020-11-04 01:49 UTC (History)
12 users (show)

Fixed In Version: NetworkManager-1.25.1-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 01:49:00 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4499 0 None None None 2020-11-04 01:49:28 UTC
freedesktop.org Gitlab NetworkManager NetworkManager merge_requests 424 0 None None None 2020-03-03 12:36:38 UTC

Description Gris Ge 2020-02-20 13:10:10 UTC
Description of problem:

When nmstate try to apply bonding options to connection profile,
got failure:

nm-connection-error-quark: bond.options: 'updelay' option requires 'miimon' option to be set (7)

But in kernel, its default value for a bond is updelay=0 miimon=0 which is legal.

Version-Release number of selected component (if applicable):
NetworkManager-1.22.8-1.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. nmcli c add type bond ifname bond99 bond.options updelay=0,miimon=0,mode=0
2.
3.

Actual results:

Error: Failed to add 'bond-bond99' connection: bond.options: 'updelay' option requires 'miimon' option to be set

Expected results:
No failure.

Additional info:

I think NM is overkill on this bond option check. It's hard for NM to track the
restrictions of kernel.

Comment 1 Antonio Cardace 2020-02-20 14:41:55 UTC
MR with the fix waiting for review: https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/424

Comment 2 Antonio Cardace 2020-02-28 14:49:51 UTC
Fixed upstream with commit 50da785be14ac976f909b29766195baaa49e1934 and backported to branch nm-1-22

Comment 4 Gris Ge 2020-03-03 11:52:21 UTC
nmstate has workaround in upstream master branch: https://github.com/nmstate/nmstate/pull/839

Comment 5 Thomas Haller 2020-04-07 15:41:40 UTC
missed rhel-8.2

Comment 9 Vladimir Benes 2020-06-22 10:05:30 UTC
test case added (correct link):
https://gitlab.freedesktop.org/NetworkManager/NetworkManager-ci/-/merge_requests/582

Comment 12 errata-xmlrpc 2020-11-04 01:49:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (NetworkManager bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4499


Note You need to log in before you can comment on or make changes to this bug.