Bug 180520 - setting RUN_FIRSTBOOT=yes doesn't work
setting RUN_FIRSTBOOT=yes doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 14:14 EST by Nalin Dahyabhai
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 16:06:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2006-02-08 14:14:46 EST
Description of problem:
If a sysadmin decides to set firstboot to run at boot-time, and finds
/etc/sysconfig/firstboot with "RUN_FIRSTBOOT=no" as its contents, it's not
unreasonable to expect that setting "RUN_FIRSTBOOT=yes" will do the job.

Version-Release number of selected component (if applicable):
1.4.3-1

How reproducible:
Always

Steps to Reproduce:
1. echo RUN_FIRSTBOOT=yes > /etc/sysconfig/firstboot
2. unset DISPLAY
3. /usr/sbin/firstboot --reconfig
  
Actual results:
Nothing.

Expected results:
Firstboot's TUI, in all its glory.

Additional info:
It looks like there's no "return True" statement to be called if "FIRSTBOOT=no"
isn't found and we fall out of the "for" loop.

Note You need to log in before you can comment on or make changes to this bug.