Bug 1805224 - openshift-ingress-operator fails in AWS China
Summary: openshift-ingress-operator fails in AWS China
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Miciah Dashiel Butler Masters
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks: 1809622
TreeView+ depends on / blocked
 
Reported: 2020-02-20 14:10 UTC by Wang Haoran
Modified: 2020-07-13 17:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The ingress operator did not use the appropriate Route 53 API endpoint when running in AWS China regions. Consequence: The ingress operator failed to configure DNS when it was running in AWS China regions. Fix: The ingress operator now detects when it is running in AWS China regions and configures the appropriate API endpoint. Result: The ingress operator can now configure DNS in Route 53 in AWS China regions.
Clone Of:
: 1809622 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:16:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:16:48 UTC

Description Wang Haoran 2020-02-20 14:10:40 UTC
Description of problem:
The operator didn't work because of the api endpoints and region are not correct.
In aws china, the route53 api endpoint is https://api.route53.cn or https://route53.amazonaws.com.cn

PR : https://github.com/openshift/cluster-ingress-operator/pull/361
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Wang Haoran 2020-03-12 07:23:12 UTC
Verified with : registry.svc.ci.openshift.org/ocp/release:4.5.0-0.nightly-2020-03-12-031748

Comment 5 errata-xmlrpc 2020-07-13 17:16:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.