Bug 1805269 - The configmap sourceType of the CatalogSource failed to connect the ConfigMap
Summary: The configmap sourceType of the CatalogSource failed to connect the ConfigMap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.2.z
Assignee: Evan Cordell
QA Contact: Salvatore Colangelo
URL:
Whiteboard:
Depends On: 1805268
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 15:36 UTC by Nick Hale
Modified: 2020-04-14 11:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1805268
Environment:
Last Closed: 2020-04-14 11:58:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1378 None closed Bug 1805269: Fix configmap registry server readiness probe timeouts 2020-04-07 11:18:52 UTC
Red Hat Product Errata RHBA-2020:1398 None None None 2020-04-14 11:58:41 UTC

Comment 3 Salvatore Colangelo 2020-04-09 12:21:16 UTC
Hi below the steps:

[scolange@scolange openshift-tests]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.nightly-2020-04-06-113246   True        False         21m     Cluster version is 4.2.0-0.nightly-2020-04-06-113246

[scolange@scolange openshift-tests]$ oc -n openshift-operator-lifecycle-manager exec catalog-operator-66c5689d4b-snt7q -- olm --version
OLM version: 0.11.0
git commit: 4f7a7cce5c7ab50c8ea6b38f0af26c4dc9bbb97b

Steps to Reproduce:
1. Install the OCP 4.2.

2. Create a namespace called "test-operators".

[scolange@scolange openshift-tests]$ oc create ns test-operators
namespace/test-operators created


3. Install a ConfigMap in it.

# oc create -f https://raw.githubusercontent.com/bandrade/v3-testfiles/v4.1/olm/configmap/configmap_etcd.yaml
[scolange@scolange openshift-tests]$ oc create -f https://raw.githubusercontent.com/bandrade/v3-testfiles/v4.1/olm/configmap/configmap_etcd.yaml
configmap/installed-community-global-operators created

[scolange@scolange openshift-tests]$ oc get cm
NAME                                   DATA   AGE
installed-community-global-operators   3      99s

4, Create a CatalogSource, which its sourceTyoe is "configmap", as below:

[scolange@scolange openshift-tests]$ cat catalogSource.yaml 
apiVersion: operators.coreos.com/v1alpha1
kind: CatalogSource
metadata:
  name: installed-community-global-operators
  namespace: test-operators
spec:
  configMap: installed-community-global-operators
  displayName: Community Operators
  icon:
    base64data: ""
    mediatype: ""
  publisher: Community
  sourceType: configmap

[scolange@scolange 1768819]$ oc create -f catalogSource.yaml
catalogsource.operators.coreos.com/installed-community-global-operators created


[scolange@scolange openshift-tests]$ oc get catalogsource installed-community-global-operators -o yaml
apiVersion: operators.coreos.com/v1alpha1
kind: CatalogSource
metadata:
  creationTimestamp: "2020-04-09T12:14:30Z"
  generation: 1
  name: installed-community-global-operators
  namespace: test-operators
  resourceVersion: "26720"
  selfLink: /apis/operators.coreos.com/v1alpha1/namespaces/test-operators/catalogsources/installed-community-global-operators
  uid: a9fd620d-7a5b-11ea-9710-065b8ecaa6a0
spec:
  configMap: installed-community-global-operators
  displayName: Community Operators
  icon:
    base64data: ""
    mediatype: ""
  publisher: Community
  sourceType: configmap
status:
  configMapReference:
    lastUpdateTime: "2020-04-09T12:14:30Z"
    name: installed-community-global-operators
    namespace: test-operators
    resourceVersion: "26653"
    uid: 9dff43b1-7a5b-11ea-9710-065b8ecaa6a0
  connectionState:
    address: installed-community-global-operators.test-operators.svc:50051
    lastConnect: "2020-04-09T12:14:37Z"
    lastObservedState: CONNECTING
  registryService:
    createdAt: "2020-04-09T12:14:30Z"
    port: "50051"
    protocol: grpc
    serviceName: installed-community-global-operators
    serviceNamespace: test-operators

after few minutes 

[scolange@scolange 1768819]$ oc get catalogsource installed-community-global-operators -o yaml
apiVersion: operators.coreos.com/v1alpha1
kind: CatalogSource
metadata:
  creationTimestamp: "2020-04-09T12:14:30Z"
  generation: 1
  name: installed-community-global-operators
  namespace: test-operators
  resourceVersion: "26821"
  selfLink: /apis/operators.coreos.com/v1alpha1/namespaces/test-operators/catalogsources/installed-community-global-operators
  uid: a9fd620d-7a5b-11ea-9710-065b8ecaa6a0
spec:
  configMap: installed-community-global-operators
  displayName: Community Operators
  icon:
    base64data: ""
    mediatype: ""
  publisher: Community
  sourceType: configmap
status:
  configMapReference:
    lastUpdateTime: "2020-04-09T12:14:30Z"
    name: installed-community-global-operators
    namespace: test-operators
    resourceVersion: "26653"
    uid: 9dff43b1-7a5b-11ea-9710-065b8ecaa6a0
  connectionState:
    address: installed-community-global-operators.test-operators.svc:50051
    lastConnect: "2020-04-09T12:14:56Z"
    lastObservedState: READY
  registryService:
    createdAt: "2020-04-09T12:14:30Z"
    port: "50051"
    protocol: grpc
    serviceName: installed-community-global-operators
    serviceNamespace: test-operators


Status : READY

LGMT.

Additional info:
[scolange@scolange 1768819]$ oc get pods
NAME                                         READY   STATUS    RESTARTS   AGE
installed-community-global-operators-bnk6n   1/1     Running   0          3m52s


[scolange@scolange 1768819]$ oc rsh installed-community-global-operators-bnk6n
sh-4.2$ ps -elf|cat
F S UID          PID    PPID  C PRI  NI ADDR SZ WCHAN  STIME TTY          TIME CMD
4 S 1001           1       0  0  80   0 - 139813 -     12:14 ?        00:00:00 configmap-server -c installed-community-global-operators -n test-operators
4 S 1001         747       0  0  80   0 -  2959 -      12:18 pts/0    00:00:00 /bin/sh
4 R 1001         770     747  0  80   0 - 12942 -      12:18 pts/0    00:00:00 ps -elf
4 S 1001         771     747  0  80   0 -  1099 -      12:18 pts/0    00:00:00 cat

[scolange@scolange 1768819]$ oc get pods installed-community-global-operators-bnk6n -o yaml|grep image
    image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:6951191faabd1fa00a86bcb05a7c1771dde94dc3f41378ed0ea13c1f7e52d118
    imagePullPolicy: IfNotPresent
    image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:6951191faabd1fa00a86bcb05a7c1771dde94dc3f41378ed0ea13c1f7e52d118
    imageID: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:6951191faabd1fa00a86bcb05a7c1771dde94dc3f41378ed0ea13c1f7e52d118

[scolange@scolange 1768819]$ oc get svc
NAME                                   TYPE        CLUSTER-IP      EXTERNAL-IP   PORT(S)     AGE
installed-community-global-operators   ClusterIP   172.30.28.106   <none>        50051/TCP   6m9s

Comment 5 errata-xmlrpc 2020-04-14 11:58:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1398


Note You need to log in before you can comment on or make changes to this bug.