Bug 1805290 - Missing tripleo-systemd-wrapper in the triplleo-ansible
Summary: Missing tripleo-systemd-wrapper in the triplleo-ansible
Keywords:
Status: CLOSED DUPLICATE of bug 1805185
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-release
Version: 16.0 (Train)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Jason Joyce
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 16:02 UTC by Sofer Athlan-Guyot
Modified: 2020-02-20 16:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-20 16:05:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sofer Athlan-Guyot 2020-02-20 16:02:54 UTC
Description of problem: Latest puddle on on undercloud update because it misses that role in tripleo-ansible:

roles/tripleo-systemd-wrapper

Exact error:

2020-02-20 13:56:50 | ERROR! the role 'tripleo-systemd-wrapper' was not found in /home/stack/undercloud-ansible-limkb4kv/roles:/home/stack/undercloud-ansible-limkb4kv/roles:/root/.ansible/r
oles:/usr/share/ansible/tripleo-roles:/usr/share/ansible/roles:/etc/ansible/roles:/usr/share/openstack-tripleo-validations/roles:/home/stack/undercloud-ansible-limkb4kv:/home/stack/underclo
ud-ansible-limkb4kv
2020-02-20 13:56:50 |
2020-02-20 13:56:50 | The error appears to be in '/home/stack/undercloud-ansible-limkb4kv/Undercloud/deploy_steps_tasks_step1.yaml': line 47, column 13, but may
2020-02-20 13:56:50 | be elsewhere in the file depending on the exact syntax problem.
2020-02-20 13:56:50 |
2020-02-20 13:56:50 | The offending line appears to be:
2020-02-20 13:56:50 |
2020-02-20 13:56:50 |   - include_role:
2020-02-20 13:56:50 |       name: tripleo-systemd-wrapper
2020-02-20 13:56:50 |             ^ here
2020-02-20 13:56:50 |
2020-02-20 13:56:50 | PLAY RECAP *********************************************************************
2020-02-20 13:56:50 | undercloud-0               : ok=201  changed=72   unreachable=0    failed=0    skipped=40   rescued=0    ignored=1


Version-Release number of selected component (if applicable):

yum list installed | grep -E 'tripleo-(ansible|heat-templates)'
openstack-tripleo-heat-templates.noarch       11.3.2-0.20200219061445.a1824a3.el8ost          @rhelosp-16.0
tripleo-ansible.noarch                        0.4.2-0.20200207140442.b750574.el8ost           @rhelosp-16.0

[rhelosp-16.0]
name=RHOS-16.0-trunk
# puddle_baseurl= .... rcm-guest/puddles/OpenStack/16.0-RHEL-8/RHOS_TRUNK-16.0-RHEL-8-20200219.n.2/compose/OpenStack/$basearch/os
baseurl= .... /rcm-guest/puddles/OpenStack/16.0-RHEL-8/RHOS_TRUNK-16.0-RHEL-8-20200219.n.2/compose/OpenStack/$basearch/os
gpgcheck=0
enabled=1



Steps to Reproduce: Install GA update to 20200213.1

Comment 1 Alex Schultz 2020-02-20 16:05:46 UTC

*** This bug has been marked as a duplicate of bug 1805185 ***


Note You need to log in before you can comment on or make changes to this bug.