Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1805292 - VM Events page keeps scrolling up
Summary: VM Events page keeps scrolling up
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 16:04 UTC by Radim Hrazdil
Modified: 2020-07-13 17:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:16:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
video sample (1.74 MB, application/x-matroska)
2020-02-20 16:04 UTC, Radim Hrazdil
no flags Details
vm page events scrolling is normal after fix (4.27 MB, video/quicktime)
2020-03-12 08:59 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4437 0 None closed Bug 1805292: Do not clear event list on error 2020-12-14 08:10:53 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:16:48 UTC

Description Radim Hrazdil 2020-02-20 16:04:26 UTC
Created attachment 1664436 [details]
video sample

Description of problem:
When a user navigates to Events tab of a VM, the page keeps scrollig up.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-17-022408
CNV 2.3

How reproducible:
100%

Steps to Reproduce:
1. Create a VM
2. Navigate to Events tab
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2020-02-23 08:55:49 UTC
Hi,

The event page is common to all elements and uses a common component `ResourcesEventStream` it looks like the 
jumping behaviour that happen on data reload is not specific to vm's and will happen for pods too (if they have
enough events, and user scroll to the bottom), do we need to move this issue core ?

Comment 2 Tomas Jelinek 2020-02-25 11:30:43 UTC
even though we provide the patch, for bookkeeping reasons moving to the core since it is a fix in the core.

Comment 5 XiaochuanWang 2020-03-12 08:59:54 UTC
Created attachment 1669589 [details]
vm page events scrolling is normal after fix

Comment 6 XiaochuanWang 2020-03-12 09:01:12 UTC
Checked on 4.5.0-0.nightly-2020-03-11-214319
Scrolling is acting as normal now, please refer to the attachment for screen recording.
This could be Verified.

Comment 7 Yaacov Zamir 2020-04-30 08:40:45 UTC
docs do not change

Comment 9 errata-xmlrpc 2020-07-13 17:16:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.