Bug 1805400 - quorum-guard: deployment is not privileged to read files from etcd operator
Summary: quorum-guard: deployment is not privileged to read files from etcd operator
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.3.z
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1805393 1805397
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 17:46 UTC by Sam Batschelet
Modified: 2020-05-14 17:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1805397
Environment:
Last Closed: 2020-05-14 17:09:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sam Batschelet 2020-02-20 17:46:19 UTC
+++ This bug was initially created as a clone of Bug #1805397 +++

+++ This bug was initially created as a clone of Bug #1805393 +++

Description of problem: quorum-guard needs to be able to read files created by cluster-etcd-operator. By setting privileged: true we will avoid possible permission issues resulting in failed probe checks. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: quorum-guard can read files without permission issues.


Additional info:

Comment 1 Michal Fojtik 2020-05-12 10:47:23 UTC
This bug hasn't had any activity in the last 30 days. Maybe the problem got resolved, was a duplicate of something else, or became less pressing for some reason - or maybe it's still relevant but just hasn't been looked at yet.

As such, we're marking this bug as "LifecycleStale".

If you have further information on the current state of the bug, please update it, otherwise this bug will be automatically closed in 7 days. The information can be, for example, that the problem still occurs, that you still want the feature, that more information is needed, or that the bug is (for whatever reason) no longer relevant.


Note You need to log in before you can comment on or make changes to this bug.