Bug 180547 - Can't register archive
Can't register archive
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bazaar (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Shahms E. King
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 17:21 EST by Jeffrey C. Ollie
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 10:45:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Ollie 2006-02-08 17:21:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
Bazaar on development won't register archives.

Version-Release number of selected component (if applicable):
1.4.2-4.fc5

How reproducible:
Always

Steps to Reproduce:
1.baz register-archive http://mirrors.sourcecontrol.net/soto@freedesktop.org--2004-personal/
2.
3.
  

Actual Results:  [jeff@devel ~]$ baz register-archive http://mirrors.sourcecontrol.net/soto@freedesktop.org--2004-personal/
arch_pfs_fs_connect: failed to get the dir for /home/jcollie/http:/mirrors.sourcecontrol.net/soto@freedesktop.org--2004-personal


Expected Results:  [jeff@fc4 ~]$ baz register-archive http://mirrors.sourcecontrol.net/soto@freedesktop.org--2004-personal/
Setting arch cache to default path: /home/jeff/.arch-cache
Registering Archive: soto@freedesktop.org--2004-personal


Additional info:

Works in FC4.  Is this maybe due to the recent upgrade to neon in development?
Comment 1 Shahms E. King 2006-02-10 12:24:09 EST
I will look into this, I suspect it is related to the neon upgrade.  In theory,
there is a 1.4.3 version of bazaar, but I cannot find the tarball anywhere.  The
Canonical website has release notes for it but no release ;-(.
Comment 2 Shahms E. King 2006-02-10 18:08:19 EST
This bug is caused by the neon update (specifically, a change in semantics for
ne_path_escape).  I've created a patch that should fix this problem and
submitted a build.  I'm just waiting on the rebuild to finish before I close the
bug (or try again).
Comment 3 Shahms E. King 2006-02-13 10:45:58 EST
I've updated the bazaar in rawhide, with a fix.  Please re-open this bug if
bazaar still doesn't work.

Note You need to log in before you can comment on or make changes to this bug.