Bug 1805493 - Incorrect permissions on /var/log/ganesha break logrotate
Summary: Incorrect permissions on /var/log/ganesha break logrotate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-ganesha
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 21:39 UTC by James
Modified: 2020-02-29 03:21 UTC (History)
4 users (show)

Fixed In Version: nfs-ganesha-2.8.3-2.fc31
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-29 03:21:03 UTC
Type: Bug


Attachments (Terms of Use)

Description James 2020-02-20 21:39:01 UTC
nfs-ganesha creates /var/log/ganesha with permissions 0775. This upsets logrotate:

Feb 20 21:32:11 skipper.cb.ettle logrotate[19724]: error: skipping "/var/log/ganesha/ganesha.log" because parent directory has in
secure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logro
tate which user/group should be used for rotation.
Feb 20 21:32:11 skipper.cb.ettle systemd[1]: logrotate.service: Main process exited, code=exited, status=1/FAILURE

The issue is fixed by changing permissions on the directory to 0755.

nfs-ganesha-2.8.3-1.fc31.x86_64
logrotate-3.15.1-1.fc31.x86_64

Comment 1 Fedora Update System 2020-02-21 01:32:58 UTC
nfs-ganesha-2.8.3-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-5ce53a644b

Comment 2 Fedora Update System 2020-02-29 03:21:03 UTC
nfs-ganesha-2.8.3-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.