Bug 180551 - beagle SqliteClient crashes when sqlite 2 is installed
beagle SqliteClient crashes when sqlite 2 is installed
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-02-08 18:00 EST by Alain Mellan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 14:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alain Mellan 2006-02-08 18:00:02 EST
Description of problem:

Start beagled --fg from home directory. Every time, I get:

Debug: Helper Size: VmRSS=28.2 MB, size=2.36, 34.0%

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Stacktrace:

in <0x4> (wrapper managed-to-native) Mono.Data.SqliteClient.Sqlite:sqlite_compil
e (intptr,intptr,intptr&,intptr&,intptr&)
in <0xffffff21> (wrapper managed-to-native) Mono.Data.SqliteClient.Sqlite:sqlite
_compile (intptr,intptr,intptr&,intptr&,intptr&)
in [0x4d] Mono.Data.SqliteClient.SqliteCommand:GetNextStatement (intptr,intptr&,
intptr&)
in [0x22] Mono.Data.SqliteClient.SqliteCommand:ExecuteReader (System.Data.Comman
dBehavior,bool,int&)
in [0x5] Mono.Data.SqliteClient.SqliteCommand:ExecuteReader (System.Data.Command
Behavior)
in [0x2] Mono.Data.SqliteClient.SqliteCommand:ExecuteReader ()
in <0xa6> Beagle.Util.FSpotTools:IsPossibleDirectory (string)
in <0x89> Beagle.Util.FSpotTools:GetPhoto (string)
in <0xe4> Beagle.Filters.FilterImage:DoPullProperties ()
in <0x19d> Beagle.Daemon.Filter:Open (System.IO.FileSystemInfo)
in <0x4a> Beagle.Daemon.Filter:Open (string)
in <0x60b> Beagle.Daemon.FilterFactory:FilterIndexable (Beagle.Indexable,Beagle.
Daemon.TextCache,Beagle.Daemon.Filter&)
in <0xc27> Beagle.Daemon.LuceneIndexingDriver:Flush_Unlocked (Beagle.Daemon.Inde
xerRequest)
in <0x2a> Beagle.Daemon.LuceneIndexingDriver:Flush (Beagle.Daemon.IndexerRequest
)
in <0x1b6> Beagle.IndexHelper.RemoteIndexerExecutor:Execute (Beagle.RequestMessa
ge)
in <0x573> Beagle.Daemon.ConnectionHandler:HandleConnection ()
in <0x139> (wrapper delegate-invoke) System.MulticastDelegate:invoke_void ()
in <0xf1> Beagle.Util.ExceptionHandlingThread:ThreadStarted ()
in <0xfff659a0> (wrapper delegate-invoke) System.MulticastDelegate:invoke_void (
)
in <0x7f6ca63> (wrapper runtime-invoke) System.Object:runtime_invoke_void (objec
t,intptr,intptr,intptr)


Native stacktrace:

        mono-beagled-helper(mono_handle_native_sigsegv+0xba) [0x814dcde]
        mono-beagled-helper [0x811daf8]
        [0x5d9440]
        /usr/lib/libsqlite.so.0(sqliteSafetyOn+0x6) [0xf9616b]
        /usr/lib/libsqlite.so.0(sqlite_compile+0x2c) [0xf83ba1]
        [0xd95701]
        [0xd955ea]
        [0xd952eb]
        [0xd95046]
        [0xd9500d]
        [0x5a5abf]
        [0x5a2a0a]
        [0x5a11dd]
        [0x59acce]
        [0x59aac3]
        [0x1f52c4]
        [0x1edbf8]
        [0x1eca03]
        [0x3bb63f]
        [0xf02c14]
        [0x1db478]
        [0x1db582]
        [0x1db478]
        [0x140de9]
        mono-beagled-helper(mono_runtime_delegate_invoke+0x36) [0x80ad824]
        mono-beagled-helper [0x80b786e]
        mono-beagled-helper [0x8155cec]
        mono-beagled-helper [0x8119d4e]
        /lib/libpthread.so.0 [0xd3e262]
        /lib/libc.so.6(__clone+0x5e) [0xc8814e]

Debug: Caught ResponseMessageException: Document element did not appear.  Line 1
, position 1.
Debug: Exception was unexpected.  Details: Beagle.ResponseMessageException: Docu
ment element did not appear.  Line 1, position 1. ---> System.Xml.XmlException: 
Document element did not appear.  Line 1, position 1.
in [0x0014e] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/System
.XML/System.Xml/XmlTextReader.cs:595) System.Xml.XmlTextReader:Read ()
in [0x0002c] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/System
.XML/System.Xml/XmlReader.cs:544) System.Xml.XmlReader:MoveToContent ()
in [0x00006] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/System
.XML/System.Xml.Serialization/XmlSerializationReaderInterpreter.cs:83) System.Xm
l.Serialization.XmlSerializationReaderInterpreter:ReadRoot ()
in [0x00022] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/System
.XML/System.Xml.Serialization/XmlSerializer.cs:333) System.Xml.Serialization.Xml
Serializer:Deserialize (System.Xml.Serialization.XmlSerializationReader reader)
in [0x0002e] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/System
.XML/System.Xml.Serialization/XmlSerializer.cs:322) System.Xml.Serialization.Xml
Serializer:Deserialize (System.Xml.XmlReader xmlReader)
in [0x00010] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/System
.XML/System.Xml.Serialization/XmlSerializer.cs:303) System.Xml.Serialization.Xml
Serializer:Deserialize (System.IO.Stream stream)
in <0x001ba> Beagle.Client:Send (Beagle.RequestMessage request)--- End of inner 
exception stack trace ---

in <0x002a7> Beagle.Client:Send (Beagle.RequestMessage request)
in <0x0003f> Beagle.RequestMessage:Send ()
in <0x00082> Beagle.Daemon.RemoteIndexer:SendRequest (Beagle.Daemon.RemoteIndexe
rRequest request)
Debug: Launching helper process
Debug: IndexHelper PID is 2830
Debug: Starting messaging server
Warn: Unable to set IO-priority for process to idle
Debug: Helper Size: VmRSS=11.9 MB, size=1.00, 0.0%


Version-Release number of selected component (if applicable):

mono-data-sqlite-1.1.13.2-1
sqlite-devel-3.3.3-1
python-sqlite-1.1.6-3
sqlite-3.3.3-1
sqlite2-2.8.16-2.fc5

libbeagle-0.2.1-1
beagle-0.2.1-1

Additional info:
I have user_xattr enabled on my home directory (ReiserFS).

It used to work before the sqlite bugs maybe a week ago. I removed ~/.beagle
completely, it doesn't change anything.
Comment 1 Christopher Aillon 2006-02-09 11:19:57 EST
This looks like the same error I get on 64bit only (please include your arch
next time).  This would be a dupe of 179228 in that case.

Marking dupe of that bug, but if this is not a 64bit platform, please reopen
this bug.  Thanks.

*** This bug has been marked as a duplicate of 179228 ***
Comment 2 Alain Mellan 2006-02-09 13:28:50 EST
Happens on 32bit platform. I'm running kernel 1884 at the moment. I'll go check
with 1826 see if that changes anything.
Comment 3 Alain Mellan 2006-02-09 13:39:13 EST
Still crashes with kernel 1826.
Comment 4 Christopher Aillon 2006-02-09 13:44:20 EST
Okay, I can't reproduce.  Can you give me the output of:
rpm -qa | grep sharp
rpm -q mono-core libgdiplus beagle

Also, does removing the sqlite2 package help?
Comment 5 Christopher Aillon 2006-02-09 13:46:41 EST
(you might need to rm -rf ~/.beagle after removing sqlite2)
Comment 6 Alain Mellan 2006-02-09 13:55:58 EST
OK, here it is:

[10:56am] localhost{~}101> rpm -qa | grep sharp
gmime-sharp-2.1.19-2
gtk-sharp2-2.8.0-1
gecko-sharp2-0.11-4
dbus-sharp-0.60-7
gsf-sharp-0.6-6
evolution-sharp-0.10.2-7
gtk-sharp-1.0.10-4
[10:56am] localhost{~}102> rpm -q mono-core libgdiplus beagle 
mono-core-1.1.13.2-1
libgdiplus-1.1.13.2-1
beagle-0.2.1-1.1

I removed sqlite2, and ... it works now. Thanks.

Something wrong in the sqlite 2/3 detection ?

Comment 7 Christopher Aillon 2006-02-09 14:12:48 EST
Yeah, I thought it was fixed in beagle.  I filed
http://bugzilla.gnome.org/show_bug.cgi?id=329488 for f-spot.  Looks like I'll
have to file another one for beagle.
Comment 8 Christopher Aillon 2006-02-09 14:16:01 EST
Okay, filed http://bugzilla.gnome.org/show_bug.cgi?id=330557
Comment 9 Ray Strode [halfline] 2006-02-15 14:00:53 EST
Joe says it's fixed in the upstream bug but the patch doesn't quite look right.
 But let's take this upstream.

Note You need to log in before you can comment on or make changes to this bug.