Bug 18056 - Failure to install pcmcia when compiling kernel
Failure to install pcmcia when compiling kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 01:46 EDT by ylitvin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 21:02:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ylitvin 2000-10-02 01:46:11 EDT
Hey
The box is dual boot Dell Inspiron 3800 and I needed to have ntfs module
(why ohhh why you don't include it with the regular kernel, I always have
to compile my own kernel to have it on every desktop i have), so I've
decided to compile my own kernel
After unpacking, compiling, installing the kernel from your rpm, i
discovered that pcmcia part (modules) wasn't installed, so I went to
/usr/src/linux-2.2.16/pcmcia-cs-3.1.19, did "make clean", make config, make
install. Still no pcmcia in /lib/modules/linux-2.2.16-mine.
Then after downloading pcmcia-3.1.20 and doing make config I've discovered
that config.mk and config.out are different from the ones in pcmcia-3.1.19.
Because your pcmcia's has PREFIX=/var/tmp/kernel-linux...... (smth like
that) in the config.mk and config.out, it never got copied into
/lib/modules/lernel-2.2.16-mine and was still left intact in the
/var/tmp/kernel-....
So after deleting PREFIX=/var/.. from config.out and config.mk the problem
went away and was installed successfully
Please fix it and put ntfs module with write support into the regular
kernel (you even have minix and OS/2 fs support, but no ntfs) or tell me
why you don't want it to be in the regular kernel rpm.
Comment 1 Alan Cox 2000-10-02 04:43:41 EDT
We don't believe the kernel NTFS is a supportable option. Nor does it work with
Windows 2000.
(Left open because the pcmcia thing does look like a bug)
Comment 2 Arjan van de Ven 2001-01-15 08:09:25 EST
NTFS write is known to corrupt and destroy filesystems, and is hence not
enabled.
The PCMCIA problem: the path in the config files is correct if you attempt to
build a new
kernel RPM with PCMCIA. Since you are attempting to build it "non-RPM", the path
is wrong......

Note You need to log in before you can comment on or make changes to this bug.