Bug 1805631 - lines in logs are duplicated
Summary: lines in logs are duplicated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1452373 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-21 08:47 UTC by Basil Eric Rabi
Modified: 2020-04-20 22:32 UTC (History)
9 users (show)

Fixed In Version: mock-2.2-1.fc32 mock-2.2-1.fc31 mock-2.2-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-07 05:05:05 UTC
Type: Bug


Attachments (Terms of Use)
requested file (14.60 KB, text/plain)
2020-03-05 12:35 UTC, Basil Eric Rabi
no flags Details

Description Basil Eric Rabi 2020-02-21 08:47:12 UTC
Description of problem:
With the recent update of mock, the lines in build.log and root.log are now duplicated.


Version-Release number of selected component (if applicable):
2.0

How reproducible:
100%


Actual results (build.log):
Mock Version: 2.0
Mock Version: 2.0
Mock Version: 2.0
warning: line 172: Possible unexpanded macro in: Requires:       grass(x86-64) = %{grass_version}
warning: line 172: Possible unexpanded macro in: Requires:       grass(x86-64) = %{grass_version}
Building target platforms: x86_64
Building target platforms: x86_64
Building for target x86_64
Building for target x86_64
setting SOURCE_DATE_EPOCH=1582243200
setting SOURCE_DATE_EPOCH=1582243200
Wrote: /builddir/build/SRPMS/qgis-3.11.0-git342e6db8285.fc31.src.rpm
Wrote: /builddir/build/SRPMS/qgis-3.11.0-git342e6db8285.fc31.src.rpm
Child return code was: 0
Child return code was: 0

Expected results (build.log):
Mock Version: 2.0
warning: line 172: Possible unexpanded macro in: Requires:       grass(x86-64) = %{grass_version}
Building target platforms: x86_64
Building for target x86_64
setting SOURCE_DATE_EPOCH=1582243200
Wrote: /builddir/build/SRPMS/qgis-3.11.0-git342e6db8285.fc31.src.rpm
Child return code was: 0

Comment 1 Basil Eric Rabi 2020-02-21 08:48:46 UTC
This was mentioned in https://bodhi.fedoraproject.org/updates/FEDORA-2020-8c3f06d776

Comment 2 Copr Team 2020-03-05 07:46:40 UTC
Thanks for the report.  I can not reproduce this, can you attach file
with `mock -r fedora-31-x86_64 --debug-config`?

Comment 3 Pavel Raiskup 2020-03-05 07:48:57 UTC
Sorry, I forgot to log-out from our team account when writing
the comment #2.

Comment 4 Basil Eric Rabi 2020-03-05 12:35:45 UTC
Created attachment 1667726 [details]
requested file

> I can not reproduce this, can you attach file
> with `mock -r fedora-31-x86_64 --debug-config`?

I can still reproduce the duplicated lines.

Comment 5 Pavel Raiskup 2020-03-05 13:12:37 UTC
Weird, nothing special in your config (I use the same).  Can you please
post reproducer?  Does this happen with each source RPM?

Comment 6 Basil Eric Rabi 2020-03-05 13:44:51 UTC
> Can you please post reproducer?

I use the command `./buildrpm.sh -s` in this project (https://github.com/qgis/QGIS/tree/master/rpm#generate-a-valid-spec-file-from-template) to build a src.rpm. It calls the command
`mock --buildsrpm --spec qgis.spec --with-other-args`
(https://github.com/qgis/QGIS/blob/3246a92db82946c8520b0d46a47025bf5268bd9f/rpm/buildrpms.sh#L155). After the source RPM is created, I see that the lines in the following files are duplicated:

1. build.log (all lines duplicated)
2. root.log (only lines after line 133 are duplicated)
3. state.log (only lines after line 7 are duplicated)

> Does this happen with each source RPM?

I only use mock to create src.rpm and rpm for QGIS. This happens to both creation of src.rpm and creating the rpms after I use 
`mock -r fedora-31-x86_64 --rebuild qgis-3.13.0-x.fc31.src.rpm --resultdir=out`.

Comment 7 Fedora Admin XMLRPC Client 2020-03-17 04:43:16 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 8 Pavel Raiskup 2020-03-19 09:04:19 UTC
*** Bug 1452373 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2020-04-02 07:48:08 UTC
FEDORA-2020-fba9845e22 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fba9845e22

Comment 11 Fedora Update System 2020-04-02 07:49:19 UTC
FEDORA-2020-6b7c342fb4 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6b7c342fb4

Comment 12 Fedora Update System 2020-04-02 07:49:45 UTC
FEDORA-2020-85df0014c1 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-85df0014c1

Comment 13 Fedora Update System 2020-04-03 19:56:08 UTC
FEDORA-2020-fba9845e22 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fba9845e22`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fba9845e22

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-04-03 20:35:08 UTC
FEDORA-2020-85df0014c1 has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-85df0014c1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-85df0014c1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-04-03 20:49:37 UTC
FEDORA-2020-6b7c342fb4 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-6b7c342fb4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6b7c342fb4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2020-04-07 05:05:05 UTC
FEDORA-2020-fba9845e22 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2020-04-07 13:16:02 UTC
FEDORA-2020-fba9845e22 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2020-04-20 22:14:48 UTC
FEDORA-2020-6b7c342fb4 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Fedora Update System 2020-04-20 22:32:01 UTC
FEDORA-2020-85df0014c1 has been pushed to the Fedora 30 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.